Upgrade to 1.4 broke printing

I upgraded to 1.4 and have not had a successful print since. I have had 4 jammed nozzles, it appears that after the first couple of layers go down the z doesn't change and it eventually jams the nozzle. I just printed the same part straight from the sd card with no issues.

Any thoughts

Hello @Rickyg!

Please don't delete the template:

What is the problem?

What did you already try to solve it?

Logs ( octoprint.log , serial.log or output on terminal tab at a minimum , browser error console if UI issue ... no logs, no support! )

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible )

1 Like

Will do @Ewald_Ikemann
Soon as I get back to my laptop

If it were me, I think I'd visit the OctoPrint Control screen and home the X/Y and then home the Z.

Just for funsies, I'd then set the movement to the smallest amount and jog the hotend assembly up once (or the bed down once) to see if it's moving. If it seems to be going in the correct direction, I'd then change the movement to the 1mm level and jog, jog, jog... to make sure that my Z axis is happy enough.

In my case, I would make sure that I've got a home axes command at the start of my print job followed by a G92 to make sure that my firmware knows that it's now at the home position.

In other words, see if your printer's Z movement is working as expected before sending jobs to it. Adjust your startup gcode so that after each reboot your firmware knows where it is.

Thanks for the suggestion.
My start code has the G92 and has work great for the past year.#It was only after the upgrade did things change. I will collect some information and share it with the community shortly.

Thanks again

What is the problem?
I have repeated Z height issues. I am on my 6th nozzle now. I keep getting nozzle jams and Z height is inconsistent. Also Cancelling a print gives me the popup are you sure and when i click ys nothing happens.
I will tweak the Z height and then I get a good print but then it goes out of wack again and the nozzle jams, i can tell its starting to go because the extruder stepper starts clacking.

What did you already try to solve it?
New filament
Z Height adjustments.#
Level the bed
New Nozzles.

I am using tOctoprint 1.4 as that was the latest update.
I have no idea what Octpi is.
The printer is an Ender 3 Pro
Browser is Chrome..latest version
OS is Windows 10 Pro.
I know it's running Marlin but I am sorry have no idea what version nor how to find it.
I will see if I have the original Bin and see if that has something.

octoprint.log (491.7 KB)

I've had my printer for over two years now and I've only replaced the nozzle once. This was because I ran 1.5KG of carbon fiber—infused through that, carving out its throat.

If you get a filament jam, don't replace the nozzle. I know, they're only a buck or so but just raise the hotend, raise the temperature to about 210 (for PLA), remove the PTFE tube and then extrude 100mm or more all the while ramming that filament into the top hole of the extruder assembly with both hands. Your additional pressure plus the feed gear doing it's thing will help to push that through.

Hey there.\Thanks I will do that to clear the log. Interesting Idea. I tried the other methods but no luck.
Still I am happy to have a method as to how to clear the nozzle. I am still puzzled why I suddenly am having these issues since I upgraded.
I should have left it alone, its been working great since I set it up months ago.

For what it's worth... (grab some popcorn)...

I bought a Robo C2 printer. The company sells it as a super-consumer-friendly printer. It looks just beautiful. They've provided their own fork of OctoPrint and Marlin. It took me about a year to figure out that they were clueless about software.

Fast-forward, I myself spent a fair amount of time getting jammed nozzles. They have an IR-based autoleveling device that's on the back of the hotend assembly which is supposed to allow a G29 to be properly setup at startup. Of course, it's an inconsistent plastic bed on magnets on a diving board of a (thin) aluminum platform. From the bed visualizer plugin it's just scary what this looks like.

Robo's software manager—by his own admission—doesn't know software. Their lead coder and he put together this incredibly ugly replacement for some of the Z-related command movements in the firmware with lots of "add this, offset that, let's reinvent reprap" sort of stuff. They knew going into this that 100% of the users would upgrade that and "air print" about 30mm above the print bed on their next print job. And yet they shipped it (I swear).

So now, I've removed all of their software and returned to vanilla OctoPrint. I didn't take their dreaded firmware upgrade. I modified my printer for manually adjusting the four corners of the print bed. I printed a carbon fiber--based under-platform support to firm that up. I removed the G29 from my startup commands since their autolevel routine and their IR makes mistakes which result in too-close printing sometimes. I'm in the process of replacing their cheap resistive/tiny TFT screen with a 10" capacitive version with an HDMI connector rather than covering all 40 GPIO pins unnecessarily.

I "dialed in" those four adjustment knobs many times over several print job starts. So I know that it does a pretty good job now. I tend to leave them alone now. I don't really have any clogged nozzle problems these days having done all that.

And remember, it has nothing to do with my (vanilla) OctoPrint version.

I'm having the same issue. I just upgraded, and I'm now getting jams at just about if not exactly the same layer each time. It didn't occur to me that it might be related to the Octoprint upgrade. If this third attempt jams at the same point I'm going to print from SD -- if that succeeds, I feel reasonably certain it's Octoprint -- especially considering I've had a truly failure free experience with this printer since day one.