Webcam stopped working. Had been fine for yearsn

Camera model

Pi camera with ribbon cable connection

What is the problem?

Webcam has stopped working with octoprint

What did you already try to solve it?

had been running flawlessly for quite some time then yesterday just stopped working "webcam screen not loaded" displayed

Have you tried running in safe mode?


Did running in safe mode solve the problem?

no (648.9 KB)

Systeminfo Bundle



Additional information about your setup

Latest version of octoprint, Raspberry Pi 3B plus, Linux. Log shows "WARNING - DeprecationWarning: Detected access to deprecated settings path ['webcam', 'snapshot'], returned value is derived from compatibility overlay. Please use the webcam system introduced with 1.9.0, this compatibility layer will be removed in a future release."

unsure how to fix

Already took in consideration that it's broken?

Yes but truthfully have not gone down the road of replacement.. a large part of that due to a log warning something about webcam not working with newer versions that I was also seeing when the camera was working.

Did you read the notes about the new webcam stack being used in 1.9.0+? There are things that need changed due to the Raspberry pi foundation changing it

No, unfortunately, I did not see those notes. Any link?

I JUST had a similar issue.
CAVEAT - my rig is not stable and a 40lb domesticated moosling knocks it off the table on a regular basis.
That being said I tried what had worked in the past, hard reboot.
No go.
So then I tried turning it OFF and back on, no go
So then I unplugged the webcamm (some logitech $20 cheapie) and brought it back up, no go
So then powered it off brought it back online, powered it pff, plugged it into a different USB port and power it back up Works great!

Yesterday I have run update/upgrade over SSH and the (ribbon) webcam stopped to work. I don't know where to look to provide more information.

Wish I could do the same but this is the ribbon cable style not USB camera

I know it's confusing because they were released at similar times (& were developed with each other in mind) the new camera stack is not part of 1.9.0 and is a separate OctoPi image download, there is also a new webcam API in 1.9.0, and is not related. You can use OctoPrint 1.9.0+ with the older images as well.

The changes the RPi foundation made to their V3 cameras don't impact older cameras that should not stop working because of the new model.

For @wildvortex: First I would check if your camera is detected by the system by running vcgencmd get_camera. For the old stack it should report supported=1, detected=1. If detected=0, then either the camera or ribbon cable is not connected properly/broken.

If it is detected, then you'll need to find the webcam logs. Unfortunately, back on OctoPi 0.17, these weren't saved as a file, so you'll have to run journalctl -u webcamd to get that. Newer versions of OctoPi save it to /var/log/webcamd.log and it appears on the systeminfo bundle.

@Gustav_Husak - if you are running the 'new camera stack' image, this is one of the problems we have been experiencing in general with this image and so it is unrelated to this topic - I would create your own if so. If you are not and are using the same (so 0.17, or maybe also 0.18) OctoPi version as @wildvortex, then please follow the above troubleshooting and share a systeminfo bundle - that's always how you can get more information, always a great starting point.

Well, removed the Pi to repair a dual USB port today. when I plugged everything back in the Camera started working again. Possible that when I pulled the printer out it wiggled the ribbon cable and got a bad connection? IDK BUt it is now working.

The only issue I now wonde about is in my LOG I am still getting this string:

WARNING - DeprecationWarning: Detected access to deprecated settings path ['webcam', 'snapshot'], returned value is derived from compatibility overlay. Please use the webcam system introduced with 1.9.0, this compatibility layer will be removed in a future release.

What is that webcam system and how do I get it set up?

I was running a Pi camera with a ribbon cable, and it worked most of the time. I ended up picking up a Logitech C270 from Amazon which works great, however, you will need to attach a bracket somehow, as the zoom is fixed.

This is a warning for developers, since a new API has been introduced but something is still using the old API via a compatibility layer, so something needs to be updated. In general we would not expect users to monitor the logs to take actions, notices are posted in the UI. Unless you have a specific problem, don't worry about warnings in the logs if you don't understand them.

Happy with the way the Pi cam runs. Like I said had been running fine for 2 or 3 years. Has IR capability so don't need to add extra lights if I want to take a quick peek at night to see how things are going.

Ribbon cable can be finicky but likely that if I had not seen the warning I mentioned a couple days before the camera went out I would have just checked that connection.

Yah, most of the time I do not worry about them. 2 or 3 days before my camera went down I was having problems with the printer shutting down with different errors. It was then that I started looking at logs and saw it. Turned out it was the broken USB ports I found. But, I noticed the warning plastered constantly in the log then bam camera stopped working 2 days later.