Webcam Stream Not Working when increasing resolution for Pi High Quality Camera

Hi everybody,

I'm struggeling to do Octolapse time-lapses with my new 12.3 mega pixel high quality pi camera.

in short:

  • camera works within Octolapse (able to take time lapses)
  • if I increase resolution -> webcam stream keeps loading (even with network cable)

Ok, now with a little bit more detail:

I' m running Octoprint1.4.0 on a Raspberry 3 B+. I recently got the Raspberry Pi 12.3 Mega pixel High Qual Camera. When I modify the octoprint.txt file to 1920x1080 resolution at 10 fps it works fine (even though the quality is not HD ... but this could be due to wrong camera settings or sth).

I can make time-lapses and everything. But since the camera is capable of taking 4k pictures I tried to increase the resolution. But when I do so (3840x2160 at 10 fps) there appears an error warning "webcam stream not loaded".

I assumed its due to a lack of bandwith so I connected my pi via a network cable but the outcome is still the same.

To decrease the necessary amount of bandwith I adjusted resoltuion and fps down to 4k at 2 fps or 2560x1440 at 5 fps. Afterwards there is no more error warning but the webcam stream remains in "webcam stream loading".

I'd be very grateful for any tips on how to solve this issue. Do I maybe need a newer Pi?

Looks like bandwidth issue. We will probably be able to resolve it when HLS support will be done.