WIFI: No with Octopi, Yes with raspian. Same Pi Board

What is the problem?

I have a working Pi Model 3 B V1.2 (actually 2 as noted below) . Running the latest version of Octopi (V0.17.0) but the WIFI doesn't work. I have properly set up the router username/PW and the country code (US) in the WPA. I've gone thru the raspi-config network options to set up the router as well but it won't allow me to do so. SSH does not recognize nor does my router see the Pi. I replaced the power supply and used different SD cards.

What's really confusing to me is that I can leave every thing the same and just replace the Octopi SD with the latest Raspbian OS and it loads with the GUI with WIFI. I can see the URL, I can SSH in, browse, etc.

Lastly I actually have (2) identical set ups. Neither worked and I got the same error messages. But while poking around trying different things the one Pi started working. Octoprint works, camera works, etc. Unfortunately I have no idea what I did... But it does validate that it can work.

I'm reasonably confident that it is a software issue. The one thing I haven't done yet is install the SD card with the working Octopi into the raspberry Pi board that I haven't been able to work. It is actually running a printer right now so I don't want to disturb it.I'm also afraid that I might mess something up and end up with two dead Octopi controllers.

What did you already try to solve it?
As stated above, I've switched gear, operating systems, power supplies, USB cables, SD cards, etc. I've tried to connect manually, using raspi-config, I've modified the WPA using Notepad++. I am no expert with Pi, Octoprint, python, etc but I can follow directions. There must be something I did or didn't do but for the life of me I can't figure out what it is...

Additional information about your network
Windows 10
ATT/Uverse DSL router.No hotspot, access points, etc. Very plain Jane set up.

As I said, the one Pi is running Octoprint just fine with WIFI, the other runs fine with an Ethernet cable but doesn't recognize WIFI using Octopi (but does with Raspbian).

Thank you in advance for your help!

The OctoPi IMG uses a file in the /boot partition called octopi-wpa-supplicant.txt which—if the update flag is set—will override what's in /etc/wpa_supplicant/wpa_supplicant.conf.

More info

you've gotta tell us what logs, conf files, commands you are running.

Did you remove the "#" in front of the wpa2 lines? I forgot this once and was pulling my hair out until I noticed my misstake.

Not sure what there is to show. Since I can't connect to WIFI, I'm not able to connect to Octoprint and so there aren't any logs. The only thing I've changed is the username/Password in the octopi-wpa-supplicant.txt. I removed the #, the lines look like this:

##WPA/WPA2 secured

country=GB # United Kingdom
#country=CA # Canada
#country=DE # Germany
#country=FR # France
country=US # United States

I've run sudo raspi-config as mentioned above. But the only thing I tried to do is configure the SSID but it kicks it out.

I did do something to get the one box to work but I can't figure out what it was...

EDIT: I just noticed that the UK country code was uncommented - could that be the issue? Can you have more than one country code?

Either GB or US - not both

FYI: WiFi regulations are different in the countries: channels, frequencies, bandwidth etc.
The WiFi module has to know exactly what to use.



I was just editing my post while you were replying. I noticed the two country codes - Seems like that is an error in the octopi-wpa-supplicant.txt not to have that line commented out like the others (or mention it in the instructions). Not being critical but I'm guessing that wasn't the intent...

I also notice that the note says that the country code is for B+. Mine is a B (V1.2). Would that make a difference? I'll make the changes and try this when I get back to my office and report back.

Thanks everyone for their comments so far.


The country code is only WiFi related, no matter what hardware you are using.

I commented out the extra country code but it didn't resolve the issue - still no WiFi with octopi.

So I took the SD card that is working, cloned it and now both Pi's are working. Some day I'll compare the working and non working files to see if I can spot the difference but for now I'm just satisfied to have them both running.

Thank you all who commented!

1 Like

Great you found a solution. So could you please: PSA: Please mark the solutions to your topics as such