WS281x LED Status Issue

Hey there,
I really need some help with that plugin. I searched the forum and net already but I could not solve it.

I installed the plugin and set up my LED. Wiring was made like recommended in the wiki (Wiring your LEDs - WS281x LED Status). The following components are used:

Raspberry Pi 3B with OctoPrint 1.6.1
for level shifting I tried:

Because of only 8 LEDs in use I do not use an external power supply but drain power from my Raspi.

The Open OS config Test passed without errors.

Nevertheless I don't get control over my LEDs via the plugin.

Without the level shifter the buttons for the LED strip test (red/green/blue/white) sometimes work and sometimes don't. Other functions like visualizing the heating process don't work at all.

With level shifting the buttons for the LED strip test (red/green/blue/white) don't work at all. The strip does not change color. I can see only a slight shift of brightness... sometimes. Additionally the first LED in the row always shows a different behaviour than the others.

The log shows no errors.

I am really desperate! Any ideas?

I just tried with an external power supply... the same issue.

Those level shifters are not fast enough for ws281x leds, from what I can see on the internet. The setup guide recommends 74AHCT125 and that is fast enough.

You may have success without a level shifter if you lowered the voltage slightly, you should be able to do this with a diode but I'm not qualified to tell you exactly what. Since it works sometimes, but not others it is likely the signal is right on the edge of what it can accept. Keeping the signal wires as short as possible will also help minimise voltage drop.

Hey Charlie,
thank you for your quick response!
I used the two logic chips because they were recommended by Adafruit... and because the 74AHCT125 was not available in my favourite shop recently :roll_eyes:
Order is placed now and the new chip will arrive on friday.
I will report again...

That's interesting - when I first got into doing all the ws281x stuff it was the 74AHCT chips that adafruit recommend... Do you have a link? Just out of interest really.

I now tried the 74AHCT125 --> same problem.
I shortened the DIN-wire to about 5 cm --> same problem.
I used a different WS2812 (no name) --> same problem.
The 8-spot-neopixel does not follow my commands. Sometimes it works and sometimes not. Sometimes the LEDs change to white when I press any color. Sometimes the right color appears and sometimes (mostly) nothing happens...
Something more I can try?

The fact it 'sometimes works and sometimes not' is the most annoying thing here. Usually this is signal-related issue, since it is getting some commands, so the software side is likely working.

Could you send a picture of how it is wired up to the Pi? I am thinking it must all be correct but maybe there's something else interfering. It's interesting that you had the same problem with the level shifter, without and with another strip - kinda ruling out that it is the strip that's caused the issue here.

Here are some pics of my setup on a breadboard...

... and the wires at the pi.

I also made a video of the malfunction

Ok, that video was really helpful. I know this is a long debugging trip, but hopefully we get there in the end.

You've mentioned you're using a Pi 3B, and they can change the clock speed. This can be configured and for the plugin to work it must be set compatible with the LEDs.

Could you post the contents of the file at /boot/config.txt? You can access this either through SSH or by shutting down the Pi & taking the SD card out, it's on the boot partition.


I am so sorry. I misread one point in your SPI-setup-instructions and added a


to my /boot/config.txt :confounded:

Now, that I cleared that entry the color change works fine. I'm sorry again...

But now i face another issue... maybe also because of my missing experience:

I tried to visualize the heating process of my hotend. I your manual you write the the heating progress is triggered by a M109 command. Unfortunately, OctoPrint sends an M104 command when heating the nozzle. Is it possible to make this two compatible?

1 Like

Most actual prints use the M109 blocking commands, OctoPrint's temperature graph controls don't. Without it blocking, there's no real way to know what point the heating will be finished unless I track the temperatures more closely. I'm always improving things and removing restrictions by writing better code. It won't be in the next update - I've already committed which features to write & haven't even managed to do those ones yet.

Ok, thank you for your patience with my "problem".
I'm looking foreward to further releases of your software!

1 Like