WS281x LED Status

I recently discovered the WS281x LED status plugin and ordered a 74AHCT125N From Amazon here -

I'm following the guide here using the "level shifting chip" section and have my breadboard wired exactly like that, including the external 5v power supply.

I have verified that my LED's are getting 5v by checking the other end of the strip using a multimeter. The guide states to use GPIO10 (I'm using a RPI 3 B+, I'm not sure if that matters) but no matter what I try I cannot get the LEDs to illuminate.

Maybe I don't properly understand how to use the plugin but I do see a light bulb on my Octoprint home page, I assume this is the power switch, this does nothing. I went into the "Utilities" tab and tried "Test ____" to change LEDs color but this doesn't do anything.

My LED Strip settings are here -
My OS Config Test results are here -

It should be noted I'm using an "Inland WS2812B-5v" strip from Microcenter.
I'm using an external 5v power supply going into the positive and negative on my breadboard.

I am not sure how well these pictures will illustrate how everything is connected but here are pics of my wiring currently.

Any help is greatly appreciated. Thank you in advance!

Could you upload the plugin_ws281x_led_status_debug.log here please? Find it under the Logging panel in OctoPrint's settings.

I have had a couple of issues recently with newer Raspberry Pi boards (rev 1.4) not being supported by the upstream library, and still waiting on a release. If you get an 'unsupported board' error in that log file follow the instructions here:

I have pasted the log here -
I also enabled debugging and posted the new log here -

Thank you for your help.

Everything in the logs looks OK from the point of the code, it seems to think it has initialised itself just fine towards then end.

The wiring picture you've attached looks good (provided the chip is the correct way around, can't tell from that).

Try taking the level shifter out of the circuit. I have had a few reports of it getting in the way and actually doing more bad things than good. I have a 74AHCT125 here with no problems, but then I also have no problems just wiring the data line straight to the LEDs.

Another thing you could try (if you can) is work out if the signal from the Pi is actually doing anything. Aside from a oscilloscope I can't think of another practical way of doing this though, not everyone has one of these.

Unfortunately I don't have an oscilloscope. Is there any other way to verify that the pi is putting out the correct signal? I verified that the LED's are getting 5v all the way through the strip.

Well I finally got an hour to mess with this and boy do I feel stupid. I had another LED strip sitting around and a spare breadboard so I connected it without the leveler shifting chip and it worked fine.

I then decided to try again with the original set of LEDs and it worked! I had the direction wrong. I could have sworn that I checked that I was plugging into the "Din" side but apparently I was connected to the "Do" side.

Sorry to waste your time but thank you for all your help! Now time to tinker with the plugin!

1 Like

Enjoy the plugin!

Thanks again! I just became one of your sponsors. I appreciate your help!

1 Like