1.3.8 Dont restart afer update


#1

Sorry, my english is very little,

My octoprint after update to 1.3.8 dont restart, i connect by ssh and I have tried the command: ps -ef | grep -i octoprint | grep -i python but dont return anything, after i have tried the command: sudo service octoprint restart but dont work

The last entry in ~/.octoprint/logs/octoprint.log is: starting upfate to 1.3.8

Thanks


#2

Hello,

A friend of mine just got the same issue.
You can revert back to 1.3.7 while Foosel is investigating.
To revert back, open putty and login and then issue the following commands :

~/oprint/bin/pip install https://github.com/foosel/OctoPrint/archive/1.3.7.zip
sudo service octoprint restart

Regards :wink:


#3

Works!!

Thank you very much

Can I update to 1.3.8?


#4

You could try again.
I've just updated mine and work without problem.
If it fails again, now you know how to revert back to 1.3.7


#5

Thank you again,

I have reinstalled 1.3.8 and everything is correct, but now I can not create folders or upload files, I could print from Cura by octoprint, but can not upload files, any ideas?

I'm sorry, I hope I'm not too upset.


#6

Hello, after reinstalling octopi i update to 1.3.8 it works fine.