1.5.1 Not connecting anymore to Ender 3

What is the problem?

1.5.1 Error: No more candidates to test, and no working port/baudrate combination detected
I had this problem with the last 1.4 release but changing the usb port worked before.

What did you already try to solve it?

Restarted the printer, changed the cable, restarted the Pi, updated the pi firmware

Have you tried running in safe mode and if so did it solve the issue?

Yes, no

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (276.6 KB) serial.log (1.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3, Raspberry Pi 3, windows, google chrome

I looked at my Pi and no /dev/ttyUSB* is showing up at all when I do ls /dev/ttyUSB*

Could this be a Pi Problem?

1 Like

Same problem here with same printer. After a night everything went back to normal, but now after I have turned off the printer for hours, it's impossible to reconnect.

If the operating system isn't even seeing the printer, then OctoPrint can't see it either. And unless it can see it it can't connect to it. Reasons for not being able to see it range from issues due to throttling (@markbot2000 based on throttle_state: '0xD0000' your Pi experienced frequency capping and throttling due to soft temperature limit - you need to look into better Pi cooling), broken cabling, hiccups on the OS, up to broken USB ports on either the Pi or the printer.

Ok, I have a cable coming later today and I will check to see if that is the problem, how would I go about checking if it is hiccups on the OS or the broken USB ports?

The cable was the fix, but I had to take out and put the microsd card back in for some reason, which changed the IP. Once I figured out that it seems to be working fine, though I did get a fan for it from your suggestion. Thank you for your help foosel and thank you for developing the software! You're a lifesaver


Seems like the cable was the problem for me!