2 Raspberry Pi 3's and Webcam Issues?! Please help!


#1

Hello,

I was hoping to find some help with getting my Raspberry Pi Cam v2 up and running with my latest printer setup. Let me explain my setup a little bit. I have 2 different 3D printers - a Monoprice Mini Delta and a Creality CR-10S. I have 2 separate Raspberry Pi 3's running the latest OctoPi image on each - 1 to each printer via USB cable and running over wifi. My Monoprice Mini Delta uses a PS3 Eye Toy cam and that streaming video in Octoprint works great and has been for several months now. I recently got a CR-10S printer so I ordered a new Raspberry Pi 3 and a Raspberry Pi Cam v2 in hopes that it'd be better resolution and easier setting up since the PS3 Eye Toy was a pain to get running. I know it's possible to run 2 instances of Octoprint on the same Raspberry Pi 3, but I didn't want to take that route. My CR-10S setup has a Raspberry Pi Cam v2 plugged in to the other Raspberry Pi 3 via ribbon cable. I can initialize it to be able to get to the MJPG Streamer Demo area via My Raspberry IP:8080 in the web address in Chrome. However, even in the demo mode, the camera area is completely whited out - I cant see anything. I have tried numerous ways to make a call to start and stop the stream, but nothing has worked yet. I even tried the SUDO KILLALL -9 MJPG_STREAMER command and then restarted the stream via: ./mjpg_streamer -i "input_raspicam.so $camera_raspi_options" -o "output_http.so -w ./www". If I don't issue the KILLALL command first, I get an error when starting the stream that states the BIND: address already in use. I was wondering if it's because both of my Rapsberry Pi 3's are trying to use the same streaming port of 8080 even though they have different IP addresses assigned to them (static IPs are assigned in my router) and are on the same network. I have also tried numerous settings in my Octopi.txt file but none of that has helped yet either. What are your thoughts? Any help is much appreciated. Thanks.


#2

Me too! I am only using 1 instance, but I get the message that port 8080 is in use and will not bind. Running 1.3.6 on a R Pi 3. I can take snapshots, but not stream. Also using the PiCam V2.
Thank you.