3/10 prints fail during printing with SerialException Error

What is the problem?

I'm new to 3D printing and got a printer 2nd hand from a friend that set it up with a Pi Zero 2 W, USB hat and Octoprint. We did a fresh image and install of octopi recently.

Small things print fine, usually less than 5 hours or so. But when printing larger prints I come back to the print head stopped mid print, not clogged or obstructed, just stopped mid layer. When I look at Octoprint it tells me: "SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)"

What did you already try to solve it?

I've tried changing cables, both from the pi to the printer (Ender 3 v2) and power to the pi. I've changed power supplies for the pi from a 1a to a full 3a adapter. I've cleaned and leveled the print, changed filaments and tried to eliminate variables. I have disabled the pi camera and the USB webcam I was trying. It happens with and without cameras. It happens when the pi is inside and outside the enclosure.

Have you tried running in safe mode?

EDIT: I tried running in safe mode, sending a print that was supposed to be 14ish hours. In safe mode the print failed to start. The bed heated up, and when I checked about 20 min later to see if it had started I had the same serial exception error in Ocotprint that I had before, but the print failed to start. I have uploaded the new sysinfo bundle below.

octoprint-systeminfo-20230122174830.zip (303.8 KB)

Did running in safe mode solve the problem?

No, it failed to start printing.

Systeminfo Bundle

logs.zip (134.3 KB)

I'm hoping that's done correctly. The log was something like 60mb so I deleted and commented where I removed what I believe was just gcode.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

It's an Ender 3 v2. Octopi running on a pi Zero 2 W connected over wifi. The pi has a Zero4U USB hat that I've taken apart and making sure it has a good connection on the pins. I haven't done much with it other than try connecting a pi camera and a no name usb webcam (logitec clone) that didn't work so I put the config back to normal to mess with later.

I'm new to 3d printing, so any help is appreciated!

So I went through the machine again to make sure nothing was connected poorly, everything seated correctly, etc.

When I tried to boot it to safe mode and do a test print it let me know that the temp reporting was wrong (Ender 3 v2) which is why I had a plugin to correct that to print normally. Am I able to print in safe mode with this printer without this plugin enabled?

You can run prints, but the temperature graph will not work correctly

Thank you, so the printer going to get the right temperatures, but just report them to Octoprint incorrectly? I'll try another larger print tonight in safe mode and see what happens.

So I borrowed another pi from a friend and I can successfully print. I'm using the same micro USB cable, the same filiment, the same sliced print.

Any suggestions, or anyone see something in the logs that I'm not able to?

Original RPi == failure, Borrowed RPi == success. Other than supply issues, I'd just replace the RPi. A RPi Zero 2 isn't that expensive. Use https://rpilocator.com/ to find one at a reasonable price.

The serial issues are caused by Ender 3 having no real filtering on the mains supply into the power supply. If you install an in line EMI filter on the mains power in or use a multibox that has an EMI filter built in then this should solve your problems. Cheers