502 Bad gateway 1.8.7

Camera model = GSSK01

What is the problem?
When viewing webcam under control tab not able to see a picture. When testing the stream it shows a broken picture icon. I tried to go to http://ipaddress/webcam/?action=stream and get bad gateway 502.

What did you already try to solve it?
I have tried Google Chrome and FireFox and get the same result. I have disabled the camera and re-enabled it. I have changed usb ports with no change. I have also tried to boot into Safe mode

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

octoprint-systeminfo-20230313040845.zip (87.0 KB)
Additional information about your setup (OctoPrint version, OctoPi version, ...)

OctoPrint 1.8.7


Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.2

Just to be sure - you know that you have to replace ipaddress with the actual IP address, right?

Yes I didnt want to post the exact IP

Unless you have a public IP address (which is highly unlikely) posting IP addresses which are private poses no security risk. There's no way anyone can find you. We may need additional network related information from you to help solve your issue and you may hide the problem from us if you edit the output in the name of "security".

Private Address Ranges

  • Class A: 10.0. 0.0 to 10.255. 255.255.
  • Class B: 172.16. 0.0 to 172.31. 255.255.
  • Class C: 192.168. 0.0 to 192.168. 255.255.

I didnt see why the ip was needed. Its

There isn't very much detailed information in your original post. OctoPrint's camera support is limited to accessing a stream URL and a snapshot URL. The rest of the support comes from software installed on the underlying operating system which appears to be OctoPi in your case. I believe the underlying OS support on your system is where the problem is but the systeminfo bundle you posted has nothing in the webcam.log

I'm not a camera support expert but there are some users in this forum that are. If you supply as much detail as possible about your camera (I didn't find anything useful by googling GSSK01) and the log from above then we may be able to get one of those experts to help.

I just collected a systeminfo bundle on my system and the webcam.log is also empty. An ls -l /var/log/web* shows:

-rw-r--r-- 1 root root    0 Mar 13 08:57 /var/log/webcamd.log
-rw-r--r-- 1 root root 5306 Feb 24 13:43 /var/log/webcamd.log.1

If this is also the case on your system, then I think we need to see your older file with data in it.