7in rpi touchscreen wont rotate

I have the latest octoprint image on my sd card. I'm running a 7in offical touchscreen.

Everything works perfect except I cannot rotate the screen just flip it.

I have tried the sudo nano /boot/config.txt

Then using

And all the other variants with that line of comand. I am sure new to coding. Any help would be great.

documentation, also here and here

You might also read this issue I posted on the Adafruit repository for their drivers. In it, I'm reminding them that not everybody loads the full Desktop version of Raspbian and that orientation of display/touch needs to work at the console level.

1 Like

Thanks soon as I get home I'll read through and see if this helps!

I've tried multiple was to get the screen to rotate. Every time on sudo reboot. It locks up at this screen.

I'm about rdy to start fresh with a new disk img.

Can you walk a noob step by step lol.

I can get octo print running, the cammra works, internet works, just cant tt the screen to rotate! Bahaha

I have lots of TFT screens; I just don't have the official one from Raspberry. Was there any documentation in the box it came in?

My son got into the boxes befor I did hes 11. If there was documentation....... Its long gone lol.

I have tried several ways to rotate the last way was using this method.

During boot the screen rotated then loaded the touchUI. When octoprint pull up it was back in landscape mode.

Ah, gotcha. Alright, so it sounds like when you installed TouchUI you also installed the Desktop (x11) system.

So you'll need to chase the method of changing the orientation in x11, not in the console.

Thanks for helping. I have tried a couple things. The end results are either it boot in vertical and freazes. Boots to octoprint but always in landscape mode.

Is there a way to trick octo print to thank it is a mobile device and go into vertical mode like when I view it from my phone. Sorry if that's a dumb question. Still very new and have a basic understanding of all this.

If you haven't already done so, I think it's now time to install the TouchUI plugin.