A couple of error messages on the printer

What is the problem?

I'm getting 2 different error messages flashing up on the TFT.
The first one is when i switch on the printer, and then the Pi powers up (I have a 5V supply from the printers PSU)
The error message says M21 Unknown command ... i see that M21 relates to the SD card (which the printer has, but from what i understand it is attached to the TFT)
So is there either a way to stop the M21 command being sent, or something i can tweak in the firmware ?

The second error message(s) comes up once the print starts .. Line number is not last line number+1, Line: xxx
This message pops up and if i clear it, another one pops up with an incremented number.
I left it alone and the print finished, but would like to understand what it is and how to fix it.

What did you already try to solve it?

Researched as best i can.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (166.6 KB) serial.log (3.0 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hi, i'm having the same issue. My artillery genius pro with marlin keep displaying M21, the sd card is attached to the TFT screen and not to the ruby 32bit motherboard. Did you solved the issue? Maybe you can help me.

You can disable SD card support in OctoPrint and it won't try and access it from the printer.

Hi, SD Card support is already disabled in Marlin fw, if i enable it the error become "No sd card". My printer have usb and sd slot directly connected to the TFT screen and not to the motherboard. This error show up always, also when not using octopring and the usb is disconnected. Also, during the print, sometimes just freeze for 1 second leaving some bad marks on the print.