Abort Print using Google Home with MQTT (or any other way?)

What is the problem?

I want to set up my smart home to abort print on the 3D printer if something goes wrong and use my Google home to do so.

What did you already try to solve it?

I'm thinking of using an MQTT - i can send one using IFTTT through adafruit, but i don't know what MQTT command i can send to the octoprint server (to which topic and what command) to make it abort print.

Have you tried running in safe mode?

Not relevant

Did running in safe mode solve the problem?

Not relevant

Systeminfo Bundle

I'm using Version 1.4.0. Don't have a bundle yet. i might upgrade soon but i'm worried of breaking changes i need to back up first. i will do it later.

Additional information about your setup

Version 1.4.0 ,Version 0.17.0, running on Raspberry Pi 3 Model B Plus Rev 1.3 , Micromake

You'd probably be better off with direct API calls, the IFTTT plugin, or possibly my MQTT Subscribe plugin (which is just a proxy to the API).

I used the MQTT subscriber and now it works. Thanks.

Out of curiosity - does the IFTTT plugin also receives API calls , now just send them?

Yeah, after looking at the plugin it seems it is only one way, going outbound to IFTTT.

Ok, so i've updated to the latest Octoptint ( Version 1.7.3) and octoprint-systeminfo-20220201112559.zip (58.3 KB)
i Can attach the system info bundle now.

I've set up the MQTT subscript , with what i hope are the right setting.

i send the MQTT command.

I see it being received on the main window, and i tested it and it looked like it worked when i did.
then a week passed i started printing again and as the filemant broke i wanted to stop it, it shows the message but didn't abort the print...


The rest parameters need whitespace inside the curly brackets. Try changing that to.

{ "command": "cancel" }

Added space. working now. thanks.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.