Access Denied when trying to set up Octopi through Terminal on MAC


#1

What is the problem?
When I type ssh octopi.local and hit enter I get this:
SLOOPY@octopi.local's password:
I then type in the password raspberry, which gets me this:
SLOOPY@octopi.local: Permission denied (publickey,password).

What did you already try to solve it?
I have re-downloaded ender and the newest version of octopi for Raspberry Pi. I have the newest Pi and I have tried three different SD cards (all 32 Gig Samsung.) I have also tried four different pis (all newest version.)

What am I doing wrong here? I am pretty new to this command line stuff and trying to learn it. I was able to internet search my way through the remote host id issues but now I am stuck.

I have also reset my modem and router with hard resets. My Piware flight tracker has no issues....

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

I assume you haven't created a new user SLOOPY on your pi but that is rather your local user on the machine you are trying to login from. Try ssh pi@octopi.local instead of ssh octopi.local - if you use the latter SSH will try to login using your current username on the client. However, that doesn't exist on OctoPi, so you have to tell it to use the user pi that in fact does exist.