Acess to Octopi stopped working

I rebooted my pi and ender 3 v2. When I try to access octopi from my pc using google
chrome I get the following error

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:
    Does not come back with any process

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host=127.0.0.1 --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log, there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart.
    Rebooted system, still does not work. Also tried power off / on raspberry pi and ender 3 v2 all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

WRITE HERE

What did you already try to solve it?

Rebbted ender 3 v2 and raspberry pi, checked all connections

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Logs show an error not sure what it means.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

Logs
octoprint.log (68.4 KB)

What happend to that log?

Did you open it and inserted new lines after 80 characters?

Please do not modify logs. They get almost unreadable.

I have now used winscp to transfer the file fron the rasberry pi to my pc.
octoprint.log (68 KB)

Either the SD card is full or it has an issue in the file system:

2023-04-25 20:27:01,004 - octoprint.filemanager.storage - ERROR - Error while writing .metadata.json to /home/pi/.octoprint/uploads
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/filemanager/storage.py", line 1860, in _save_metadata
    to_bytes(json.dumps(metadata, indent=2, separators=(",", ": ")))
  File "/home/pi/oprint/lib/

Via SSH enter

df -H

and post the result.

Filesystem Size Used Avail Use% Mounted on
/dev/root 15G 15G 0 100% /
devtmpfs 1.7G 0 1.7G 0% /dev
tmpfs 1.9G 0 1.9G 0% /dev/shm
tmpfs 1.9G 8.6M 1.9G 1% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup
/dev/mmcblk0p1 253M 49M 204M 20% /boot
tmpfs 379M 0 379M 0% /run/user/1000

you're correct it shows 100% used, not sure how?

Do you have stored all the models you printed on it or other stuff?

You can use the du command to figure out where the space is being used. See https://www.hostinger.com/tutorials/vps/how-to-check-and-manage-disk-space-via-terminal.

1 Like