Achievements shows error

What is the problem?

Achievements shows error:
There was an error with the template dialogs/about.jinja2 at line number 48: unsupported format character 'Z' (0x5a) at index 93

What did you already try to solve it?

reload Octoprint, reboot Octoprint Pi

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (112.8 KB)


Additional information about your setup


The ready-to-go Raspberry Pi image with OctoPrint

Version 0.17.0, running on Raspberry Pi 3 Model B Rev 1.2


Same error here, since update to 1.10.1

Same here, found this morning

How can this help to find a solution?

@pc-bastler provided a systeminfo bundle.

Do you think if I provide an additional one, the situation will be better? 2 person already provide a bundle, are you sure a third one will help more? If yes I've no problem with that. If not, my message was the hint that this isn't a problem of only two persons. That was my intention with the message.

I only count one.

Just to say

Does not help at all.

It's only meant to build up pressure on the devs.

1 Like

More than one systeminfo bundle is certainly useful, as it allows us to spot patterns or common characteristics of your OctoPrint install, to work out why the issue is occuring. Just adding "me too" doesn't do this.


Well, no problem, here you are. (119,2 KB)

No problem at all, a fresh one - some minutes ago. (125,7 KB)

@Charlie_Powell @foosel could this be something related to a json timestamp, which typically includes a "Z" value at the end for timezone offset?

1 Like

Known issue, fix ready for 1.10.2:

Until then, switch to English (User Settings or Settings > Appearance, or ?l10n=en on the URL), this only affects the German translation.

1 Like