Adjust z offset during print causes head crash

What is the problem?

I'm just about done trying to get Octoprint to work. Any time I try to adjust the z offset during a print it causes the head to crash in the build plate. I have never had this issue with the printer before trying to connect it to Octoprint via Pi 4. I have tried everything that I can think of (manual bed level, auto bed level, measured with precision tools, used just about every guide I could find).

It's not the printer, its Octoprint. I have verified this over a dozen times and I'm just about sick of messing with it just to get one feature I want which is NO MORE SD CARDS. But I will gladly go back if it saves what's left of my glass build plate and quite wasting my time.

If you need more info, please ask.

What did you already try to solve it?

Safe mode, different slicers, different settings, manual bed level, auto bed level, measured with precision tools, add/remove plugins, reinstalled Octopi MANY MANY times, tried different versions, 1.8 is crap as I got new issues, went back to 1.7.3.

Have you tried running in safe mode?

Didn't help.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (118.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.7.3
Python 3.7.3
OctoPi 0.18.0
Pi 4
Eder 3 v2 (w/ BL touch + Dual Z + Direct drive)

As long you don't tell why, it can't be fixed.

Already tried to set the z offset in the firmware?

How are you trying to adjust the Z offset? Through the terminal in OctoPrint? Then M851 command? The printer's LCD menu?

Is your printer running the stock firmware? or something else?

Based on your past posts, one of the 'extra problems' that the 1.8.0 update caused was the wrong profile being selected in your slicer - please make sure you are absolutely sure that the problems are actually the fault of OctoPrint before throwing around stuff like '1.8.0 is crap'.

Sorry for the late reply, between work and cleaning the basement, I've haven't had much time for anything else.

1.8 just didn't want to keep some settings so I went back to 1.7. I have an idea it's a Python/plug-in issue.

Back to the Z offset, it doesn't matter what method I use. Any of the methods, changing directly on the printer, terminal, octodash, etc, it always causes the extruder to crash into the build plate. I have tried different settings in Cura thinking it's a gcode issue but it's not. I tried a gcode model that had no issues before and is now having issues. I'm not sure what else to check.

Is there another plug-in or method to change the Z offset?

I believe the firmware version I have on my ender 3 V2 is "Marlin-2.0.1-HW-4.2.7-mainboard-V1.1.2-compatible with BLTouch and filament detection".

I'm done trying to get Octoprint to work with my printer. No matter what I do to adjust the z offset, up or down, Octoprint moves the extruder DOWN first causing it to hit the build plate. This all started with an update and have tried going back to the version I had before but apparently a plug-in or something else got updated/installed a newer version than I had before. I'm sick of scrapping prints, nozzles and scratching my build plate. Now I have a Pi 4 to reuse or sell.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.