After creating new octoprint sd it can only be accessed from windows


What is the problem?

After reinstalling octoprint after the sd card failed, I
Found that I can only access it from a windows desk top. I use both android and iOS as well normally but now the ask for a login. I don’t have a login set up on for this device.

What did you already try to solve it?

Tried both the android and iOS devices and the ask for a password. Chrome on windows does not.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


We are not omnipotent. If you don't give us the details we ask for in the template, we can't provide you with a detailed answer.

If you installed the latest version of OctoPi (0.18.0) then you got OctoPrint 1.5.x which DOES require a username and password to use the web interface. There is a second username (pi) and password (default raspberry) that is used to login to the operating system (usually via SSH).

The web interface username and password are configured the first time you connect to OctoPrint. Once configured, it is possible to configure OctoPrint so that connections from your LAN (local area network) do not require a username and password.

The latter is what I think I need. I can log in to octoprint on my main design computer (win 10) with no prompt for the password, but then if I try to log in on my iPad (ios) I am prompted for a pw. Same on my phone (android).

You say I can turn off the ow requirement for web access. How do I do that?