After M600 and M108, PurgeMore/Continue does not work from OctoPrint

Issue: I am trying to get M600 to work properly. I enter M600 in the OctoPrint Console, it pauses the print and parks the print head. It sits there, until I do a M108, then it starts doing a purge. During this Octoprint pops up a message for every step. After the first automatic purge, I get prompted "Purge More" or "Continue". If I hit either one it just sits there and I can't continue or purge more via OctoPrint. This was a problem with the stock TFT28 I have my SW X1 as I can't take any action via the mutual exclusiveness and limitations of the serial port. I got a TFT35 v3 this weekend and I was able to "Purge More or Continue" via the Marlin Mode LCD emulator. Interesting when I clicked "Purge More" from the LCD, it would purge more and prompt the message again on the OctoPrint. So there is communication, going between it, though the printer is not taking the input when I click "Purge More or Continue". I attached logs for a print where I recreated the issue, then resumed the print via the LCD after I failed to do so via OctoPrint UI. I don't know if this is an issue with me, Marlin or OctoPrint.

Work Around: Buy a TFT35 and use the LCD.

OctoPrint Version: 1.4.0
Version 0.17.0, running on Raspberry Pi 4 Model B Rev 1.1
Printer: Artillery Sidewinder X1 v4
Firmware: Marlin (My configurations)
Browser: Firefox 76.0.1
OS: Windows 10 Pro

Stock Main Board: MKS Gen L
Current Main Board: BTT SKR 1.4T
Stock Display: TFT28 1.0
Current Display: TFT35 v3 (Dual mode w/ Marlin LCD)octoprint.log (48.7 KB) serial.log (627.9 KB)

Unless I'm completely confused, M600 is a Marlin firmware gcode command and "At this time M600 requires an LCD controller".

Not sure if "At this time" refers to only to Marlin v1 and Marlin v2 has expanded the options to control the process.

1 Like

I did see that and that was one of my first thoughts, though someone I am talking to on the OctoPrint Discord said they can do it all from OctoPrint and they don't need to touch their LCD. I am also a little confused why I get so far with the M600 command, though get stuck on purge more or continue.

I just tried an M600 on my LulzBot TAZ 6 with Marlin 2.0.x and it appears to work correctly (i.e. I didn't need to touch the LCD).

I did notice that you need (from M115 report):

Instead of M108, M876 is being utilized.

I loaded the latest supported Marlin firmware for the TAZ 6, and the M600 behaves differently. M115 reports Recv: Cap:EMERGENCY_PARSER:1 but no PROMPT_SUPPORT

Send: M600
Recv: //action:pause
Pausing on request of the printer...
Recv: echo:Insert filament and press button (or M108)
Recv: echo:busy: paused for user
Recv: echo:busy: paused for user
Send: M108
Recv: //action:resume
Resuming on request of the printer...
Recv: ok P15 B3
Recv: echo:Unknown command: "M108"
Recv: ok P15 B4

Thanks, that is good to hear!

What main board do you have?

Also do you have a copy of your configuration files for your FW? Wondering if I have something wrong there.

The main board on the TAZ 6 is a RAMBo 1.3L. The config file contents are enumerated in the (3.0 KB) file.

For the Marlin v2 firmware, (68.1 KB) should be the configuration files for that.

I can tell that by the amount of changes you made to the fans, you must sit near your printer :slight_smile:

Thank for attaching your config, I made a few changes to mine, sadly it didn't work. I tried a few different commands and nothing is input to the screen, though when I put M108 it is echoed to the screen. I tried M410 and that did take. I would like to know why M108 isn't working for me...hrmm...