After OctoPrint firmware update plugin update - Prusa i3 MK3 will no longer connect

What is the problem?
after updating Firmware Updater (1.3.0)
Prusa i3 MK3 no longer connects

What did you already try to solve it?
restored to an earlier point

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPrint : 1.3.10
Prusa FW 3.7.0

serial.log (444 Bytes)
<a class="attachment"

octoprint.log (126.5 KB)

Hi @davidewen!

the serial.log appears to be empty. You may have to activate the serial logging first:

Sorry about that!

Here you go.

serial-2.log (3.5 KB)

As for the serial log, OctoPrint connects fine to your MK3.
But there is a timeout problem.

2019-04-28 00:14:38,332 - Recv: echo:SD card ok
2019-04-28 00:15:07,179 - Recv: MMU not responding - DISABLED
2019-04-28 00:15:37,209 - There was a timeout while trying to connect to the printer

I have a MK2.5S with MMU2S without timout problems.
Disable the FIrmware Updater for test.
You also can increase the timeouts:

1 Like

I experienced this behaviour to, running OctoPrint : 1.3.11rc3 and a customized version on my Prusa i3 MK3 3.7.0.

Because Prusa announced problems with "busy" processing especially during z-calibration and when the MMU2 experineces a load failure and because Prusa claimed there was a fix for that, I run the Prusa 3.7.0 with this fixed merged into it. The pull request is here:

Another PR decribes pretty much the symptons of the problem I have, this is here: There, even downgrading does not help, only a XYZ calibration.

I did disable the firmware updater, this had no effect at all.

My serial log is similar to other posts, octoprint doe not get a response and times out. The timeout is not unreasonably short: there simply is no response. This is my serial.log, it seems to receive one "start" for the printer and then no resposnse anymore.

Personally I suspect the printer, not Octoprint. Will investigate further.

2019-05-06 23:48:43,421 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log
2019-05-06 23:52:52,498 - Enabling serial logging
2019-05-06 23:52:59,402 - Changing monitoring state from "Offline" to "Detecting serial port"
2019-05-06 23:52:59,443 - Serial port list: ['/dev/ttyACM0']
2019-05-06 23:52:59,443 - Connecting to: /dev/ttyACM0
2019-05-06 23:52:59,458 - Changing monitoring state from "Detecting serial port" to "Opening serial port"
2019-05-06 23:52:59,462 - Connected to: Serial<id=0x6c050390, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
2019-05-06 23:52:59,463 - Changing monitoring state from "Opening serial port" to "Connecting"
2019-05-06 23:52:59,569 - Send: N0 M110 N0125
2019-05-06 23:53:11,763 - Recv: start
2019-05-06 23:53:11,784 - Send: N0 M110 N0
2019-05-06 23:53:41,808 - There was a timeout while trying to connect to the printer
2019-05-06 23:53:41,829 - Changing monitoring state from "Connecting" to "Offline"
2019-05-06 23:53:41,869 - Connection closed, closing down monitor


I can't remember how I solved this problem, but I think this is what I did.

  1. Rebuilt Octoprint from scratch
  2. Flashed FW on i3 MK3

But, I'm pretty sure it was the rebuild of Octoprint that solved it for me.
If I remember correctly, flashing the FW did nothing.

I am up and running with no further issues.
I even run all the same plugins (minus the FW updater - because I run the Slice Engineering high temp thermistor, I had to mod the FW, so I don't want the stock Prusa FW on my machine.)

I hope this helps. Not fun rebuilding from scratch, but fortunately it doesn't take too long.

After XYZ calibration and first layer calibration, the behavior is still the same. I increased the relevant timeout from 30s to 90s. Other than the obvious longer wiat, nothing changed. Apparently what worked for others (I tried XYZ calibration, filament detector switching on and disabled octoprint plugin firmware updater) did not work for me.

OK, will try a fresh install... Not tonight however, thnx for the tip. In the same boat with the Prusa firmware: Bondtech BMG extruder is not compatible with stock MK3S/MMU2S firmware. I am suspicious however, since right now Prusa has ackowledge "porpblems" related to sending commands over their serial bus and they have a braqnch with a fix (and other unrelated cleanup) that they claim to fix it. It might depend however upon other merged branches, but they have not shared that/ nor which one they merged when they tested their fix. I therefor fear an incomplete fix, no simple way to find out without more disclosure or a new build of 3.7.0+ that integrates their fix properly.

interesting. I did not know about the issue, other than experiencing it myself.

I am using 3.7.0 FW
And I only had the issue after updating Octoprint. Prior to the Octoprint update, 3.7.0 was working. And after the rebuild it also worked. Strangely enough, I have not received any other update notices in Octoprint. I figured I would get one since I rebuilt.

I am wondering whether I broke my serial port in my printer.

This is what I did:

Rebuilt octoprint, now on version 1.3.11, new SD card.

Since it still wouldn't connect I:

  • Swapped USB cables and unplugged my USB cam (the Logitech cam was working) NO SUCCESS.
  • Used another Pi3B I had laying around NO SUCCESS
  • Installed an old firmware for my printer (Original Prusa i3 MK3), one from beginning 2018 NO SUCCESS

So bottom line: the printer works fine from SD card AND I can flask firmware on it through the same USB connection and USB cable, but not from tow different Pi's I have tried with a brand new octoprint image on it. (No plugins installed whatsoever).

It "seems" to physically connect, but then not get a response from the printer after the: Send: N0 M110 N0*125 . The timeout is not unreasonable (out of the box it has worked well before, and I did already try increasing it to two minutes...

It still gives me this:
Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: ['/dev/ttyACM0']
Connecting to: /dev/ttyACM0
Changing monitoring state from "Detecting serial port" to "Opening serial port"
Connected to: Serial<id=0x72e5ea10, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from "Opening serial port" to "Connecting"
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

OK... here comes the embarrassing part :flushed::flushed::flushed:

I know the cause and feel like a real beginner.... but

I noticed when resetting the printer to factory, when going from MK3 to MK3S, it also switch the built in RPi port on... That makes the USB unavailable for serial communication on a "Original Prusa i3 MK3".

Switching it back "off" made everything work again.

Sorry for bothering you with this non-octoprint issue, will leave the text here just in case someone is puzzled like me after a firmware upgrade that changes the setting as a result of factory reset caused by printer type change.

1 Like

Changing the RPi port off fixed it for me too.