After stopping a job for xyz reasons, I have to rename the file

What is the problem?

Weird issue since always on my setup.

If I stop a job for any reason, at exemple 10%, I have to rename the uploaded file. If not, the printer will ghost printing after 10%. I mean, no filament will be extruded, but the hotend/head will still move. If I download the Gcode, rename the file and reupload it to the Octoprint instance, I'm good.

This is the file AI3MEGA_04_GPLA_Shiny_Jarv_05-34-4634.gcode (2.2 MB) I tried to print, but it does the same thing on any stopped job,

What did you already try to solve it?

Changing Marlin firmware version (I'm using the last source from this repo, Octoprint in safemode

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs (325.0 KB)

Additional information about your setup

Printer : Anycubic Mega S, updated Mk4 Carriage + BL Touch (the issue was there way before the upgrade)

Octoprint Setup : Octoprint in a docker instance (octoprint/octoprint:latest, 1.5.2 at this day)

does this happen for every print or just that print? If so, it could be a slicing issue.

Your serial logging seems to be disabled, so there is no information in those files.
The z_probe plugin seems to have some issues.

In none of the octoprint.log files I can find a safe mode run.

Please try again.
Also try to upload the firmware to the printer again. Or try another source.

1 Like

Any print I stopped before from any gcode, I have to rename the file.

Thanks, I will enable serial logging.

Thanks about the Z_Probe. I hardcoded the probe offset 2 or 3 days ago. I think I'll disable it.

I tried a lot of firmwares from many sources, I compile myself the firmware with Arduino IDE.

I'm sorry about the safe_mode. I used it on my last octoprint docker instance. I'll do it on this one, but it i'm sure it won't do anything. I hope with serial log, I'll get something. Thanks!

1 Like