After update, server is not starting

What is the problem?
Since I updated my octoprint server to the latest version using the webpage I can no longer 'see' the server or get it started. But I can see octoprint at the same (static) IP.

What did you already try to solve it?
I have SSH'd in to the pi at using pi (user) and raspberry (pass).

I have done:

$ ~/oprint/bin/pip install 

and then

$ sudo service octoprint restart 

to no avail. I have also done

$ sudo service octoprint start 

for good measure.

I see an 'The octoprint server is currently not running' error message at the servers ip address in my browser, whereas before I would be able to log in with my username.

When SSH'd in:

$ ps -ef | grep -i octoprint | grep -i python 

returns nothing. Just a next line prompt.

I have attempted to start octoprint in safemode and then do a restart but that didn't work either. I didn't see any error messages in the terminal but the web access continues to show the same - not currently running error.

I have updated pip (I think I'm regretting that now) and tried upgrading the server to latest again but still no joy. I am at a loss.
My log file only has entries of the last time I used the server (to update it) 5 days ago. Any actions I am taking now are not being written to the file...

Systemctl status has no failed units,

So I'm very open to suggestions... before I do a fresh install.

1 Like

Try starting it manually via SSH:

sudo service octoprint stop
~/oprint/bin/octoprint serve --debug

That will hopefully print out some kind of error messages. Share the output.

Thank you for the response. Unfortunately no error messages were output after following your two commands.

My /.octoprint/logs/octoprint.log file still only shows entries from 20 May. Despite updating the Pi and Octoprint, starting and stopping the service numerous times.

And what happened instead? Share the output please :wink:

It just went straight to next prompt - as if the command executed normally and no error messages were detected.

pi@octopi:~ $ sudo service octoprint stop
pi@octopi:~ $ ~/oprint/bin/octoprint serve --debug
pi@octopi:~ $

That seems nearly impossible. How about these:

~/oprint/bin/octoprint --help
~/oprint/bin/octoprint --version
ls -l ~/oprint/bin/octoprint

You've piqued my interest now. I don't understand how this is possible either, but it may appear that my install has been borked - technical term. Nothing returns for help or version flags. Should I just reinstall at this point?

pi@octopi:~ $ ~/oprint/bin/octoprint --help
pi@octopi:~ $ ~/oprint/bin/octoprint --version
pi@octopi:~ $ ls -l ~/oprint/bin/octoprint
-rwxr-xr-x 1 pi pi 0 May 20 15:32 /home/pi/oprint/bin/octoprint

Probably should. Size zero file is contra-indicated for a program that will run successfully :slight_smile:
Here's what the top of that file looks like on a fresh install for me, fwiw:

# EASY-INSTALL-ENTRY-SCRIPT: 'OctoPrint==1.3.11','console_scripts','octoprint'
__requires__ = 'OctoPrint==1.3.11'
import re
import sys
from pkg_resources import load_entry_point

if __name__ == '__main__':

Obviously being blank seems strange.

1 Like

Fresh install fixed it. No idea what went wrong doing an update...

Is this another PiHole drive-by shooting?

Interesting you should say that as I was running PiHole on a different Pi on my network. Can you point me towards the thread(s) that discuss that? I would love to know what happened.

No, but the search feature up there in the upper right corner can. Look for pihole and update.

I found this Network error while checking for updates

1 Like