After Updates The Palette Pulls The Filament Without Stopping For Meters And Meters

What is the problem?


What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

After the arrival of Palette S I was excited and naive ..... maybe in the first tests I skipped steps. KEY RING NOT FINISHED! Notification of not having communicated M0 to the printer! ???? So I decided to do it all over again: Set factory values, firewall 2.9.2 and switched to Palette the two-color keychain (colored according to the recommendations). In the Gcode I put the initial and final codes that I usually use in Repieter Host and I was already happy with Palette, ... then I activated the RESISTANCE and the run-out mode. Still reporting that you have not communicated M0 to the printer! From today, however, AFTER UPDATES THE PALETTE PULLS THE FILAMENT WITHOUT STOPPING FOR METERS AND METERS ... THEN I HAVE TO TURN OFF THE PRINT. BUT WHAT HAVE I DONE BY WRONG? HELP!

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


First of all there is no need for screaming / uppercase sentences. Calm down.
Secondly please fill out the form and upload the logs or we can't figure out what's going on.

No idea what that means.

Which firewall?

Which update? Octoprint, the printer, the palette?


You also have to take into consideration this could be a bug with the palette plugins, and some unknown incompatibility with the newer versions of OctoPrint.

Scusa...non stavo urlando....faccio DAD ai bimbi di una 1° elementare e devo sempre scrivere in maiuscolo! Scusa
Quindi ritieni che debba aggiornare la mia Palette togliendo i plugins che ho installato? Se puoi mi indichi quale metodo possa togliere i plugin installati e quali mi consigli. vorrei ricominciare da zero, ma non so quali siano i passi da fare: consigli il run-out, RESISTENZA,ecc. Dopo queste scelte è accaduto tutto, mentre utilizzavo la modalità RANDOM per creare filamenti di più colori. Da allora non ascolta più i comandi! Ho varie volte fatto il ripristino con impostazioni di fabbrica. niente! Palette tira fuori filamento per metri e metri, non lo taglia e non si ferma! ....anche con il solito file del portachiavi test a due colori che ho già utilizzato in precedenza. Ho trovato la notizia in una guida che in modalità accessorio (io utilizzo Canvas Hub) la Palette con RUN OUT tira filamentos, senza fermarsi. Tu ne sai qualcosa? Allora non posso utilizzare run-out con Canvas Hub? Se puoi prendermi per mano e portarmi fuori da questo incubo ti ringrazio. Ora provo da sola a disistallare i plugin, ma non ho la più pallida idea di come si faccia. Ciao. Ti prego aiutami.

No worries :slight_smile:
You should try to answer in English because I don't know if any of us speaks Italian - at least I don't :wink:

Sorry ... I wasn't screaming .... I do DAD to 1st grade children and I always have to write in capital letters! Sorry So do you think I should update my Palette by removing the plugins I have installed? If you can tell me which method can remove the installed plugins and which ones you recommend. Thanks .... I would like to start from scratch, but I don't know what the steps are: advice on run-out, RESISTANCE, etc. After these choices it all happened, while I was using the RANDOM mode to create filaments of multiple colors. He hasn't listened to commands since then! I have done a factory reset several times. ...but nothing! Palette pulls out filament for meters and meters, it doesn't cut it and it doesn't stop! .... even with the usual two-color test keychain file that I have used before. I found the news in a guide that in accessory mode (I use Canvas Hub) the Palette with RUN OUT pulls filamentos, without stopping. You know something about this? So can't I use run-out with Canvas Hub? Now I have reset to factory settings, after removing the installed plugins and updating the Palette to the latest firmware. But still nothing! If you can take me by the hand and take me out of this nightmare, thank you. Now I try to uninstall the plugins myself, but I have no idea how to do it. Hi. Please help me. Lodovica

.... I remembered that all this happened after trying the MULTI-SPOOL mode. can you understand why? THANK YOU FOR YOUR PATIENCE TO HELP ME. Lodovica

My printer is a Tronxy A8 works fine on its own (see video), Palette S and Canvas Hub S. Please help me understand why the Palette does not see requests. I would like to start over and start printing in color again. I beg you. Help me!

video of my press

(Attachment stampa MANO Video 2021-03-06 at 23.19.44.mp4 is missing)

Hi, I'm really desperate ... As soon as I bought Palette S and my Tronxy A8 printer (self-made copy of Anet A8) they got along very well ... I printed, in accessory mode with Gcode and File maf. Then I bought Canvas Hub S2 (I'm connected with the Canvas firmware update to Octoprint) believing it could help me .... but maybe I didn't immediately take the right steps in the calibration and got the colors wrong, putting them in different places from the drawing by I also entered the Run.out and Resistance settings. I tried the features and since I tried Multi.spool the palette doesn't react anymore! Keep turning on just the 1st drive and asking for filament only from that driver, whatever you are asking, even if you are asking to print the usual Canvas calibration keychain. In your guide it said I had to set factory settings to update Palette with a newer firmware, and there was also a link to download the update for main, screen and graphics. (All done!) I ask for help to get out of this nightmare! Please tell me how I can get back to the press. Thanks ... can't wait to wait.
I have to use the Google translator ... sorry


Don't worry about the translator - everything is fine.

The problem is I have never seen nor used a Canvas Palette before.
So I can't really tell you what to do.

I'll try to find something useful on google and post the results later. there is no one that you know has had these troubles after Canvas Hub update .... so contact Mosaic ... maybe it's a Palette problem. But can you set to go back and remove the update to Canvas Hub too, that is, remove the octoprint firmware and go back as when I bought it to try to see if I made a mistake? Thank you, thank you. Ciao

Since you have a problem with a Palette and CanvasHub, you really should talk to them and their support. They are a third party product that no one here that I know have has access to.

well...technically you do...I just haven't used mine in a long time.

Apparently so long that I had no clue XD

Well, to be clear, I have a Palette 2. I don't have a CanvasHub but did use their plugins when I did use it. I believe I haven't used it since prior to 1.5.0, so there very well could be a bug with their plugin and newer versions. I always used the Canvas slicer online though and never used the other post processing method.