After upgrade to Creality V4.2.7 I have issues

Ender 3 V2
Recent upgrade from Mainboard V1.1.3 to V4.2.7 Silent
Raspberry Pi 4
OctoPrint via browser running Windows 10
Creality firmware: Ender-3 V2_4.2.7_Firmware_Marlin-2.0.1_V1.0.1_TMC2225.bin
No BL Touch
I am using GPIO 27 (pin 13) through ground (Pin 14) with the Filament Sensor Simplified plugin.
I use Cura slicer
I have been using Octoprint since late 2020, I have it installed on a second RPi attached to a CR-10 S4. Both systems were working as they should prior to swapping the Ender mainboard. The CR-10 still works fine with it's stock board. I am using a Power Blough'er on the USB to the printer.
Blobby stool is with new mainboard through raspi. Good stool is with new board using the SD card.

What is the problem?

After the mainboard upgrade, I am having problems printing via PI through the web interface. I have no issues connecting to the Ender 3, I can control the bed & nozzle temps with no problems. There are no problems uploading a file to the SD card and using that to print. When I upload the file to the Raspberry Pi and try to print it, the printer first does it's purge line on the side. Then the nozzle moves near the center and squirts out a large glob. It then proceeds to start printing over the top of the blob while beginning the (brim in my case) print. During the first layer, the nozzle dances all over sometimes printing the layer over previous brim lines. If I let the print go longer, the brim never finishes and the machine starts printing the first layer without walls and will continue the print without any walls.

I can print just fine using the SD card with or without the Pi connected. I can view and modify the temperatures in the browser when it is connected.
I noticed in my new printer profile the bed size was too small, making the change didn't fix anything.

What did you already try to solve it?

I tried:
I created a new printer profile in Cura and in Octoprint
Reflashing the Creality firmware;
Flashing with an Ender-3 Pro firmware (didn't work because of the display panel);
Re-flashed with proper firmware;
Formatted and re-imaged the OctoPi SD card using Raspi imager;
Went through all the wrench stuff in Octo web interface;
Tried to print a different item, tried reslicing item.
I updated my Pi via SSH after figuring out with new software I needed a new API key (that was fun :wink: ).

Have you tried running in safe mode?

Get warning because firmware plugin isn't working:

Warning: Firmware Broken

Your printer's firmware is known to have a broken implementation of the communication protocol. This may cause print failures or other annoyances. You'll need to take additional steps for OctoPrint to fully work with it.

Did running in safe mode solve the problem?

No.

Systeminfo Bundle

Wbrowser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.61 Safari/537.36
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 8228372480
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
printer.firmware: Marlin Creality 3D
systeminfo.generator: systemapi

Additional information about your setup

Ender 3 V2
Recent upgrade from Mainboard V1.1.3 to V4.2.7 Silent
Raspberry Pi 4
OctoPrint via browser running Windows 10
Creality firmware: Ender-3 V2_4.2.7_Firmware_Marlin-2.0.1_V1.0.1_TMC2225.bin
No BL Touch
I am using GPIO 27 (pin 13) through ground (Pin 14) with the Filament Sensor Simplified plugin.
I use Cura slicer.
Linux and it's software are not my primary language. The Raspberry Pi B was my first foray into Linux.



octoprint-systeminfo-20211003153401.zip (37.3 KB)

Hello @Tinker0000 !

This is not the list you see, it's the file that is linked at the end of that list.

The logs inside are most helpful for us to help

I put the whole zip into the post. Does this work?

From time to time you have a quite bad USB connection to the printer:

| Send: N144 G3 X89.456 Y182.555 I4.561 J-2.293 E25.68956*72
| Recv: echo:Unknown command: "<ðÎ?ü<,üÌx888?8x88<<8888<8<8<><>>8Î>>8> øx8ž><<<<8888xx888888"
| Recv: ok
| Send: N145 G2 X88.983 Y179.382 I-335.881 J48.448 E25.79626*112
| Recv: echo:Unknown command: "01Á000œ<Î88<<><>þ<><>þþ>þ>øÆÆ>>ø>þ<><<<<<Ž><Ž>>>~~>þþþ>>þþþþ>þþþþ>þþ>þþ>>>"
| Recv: ok
| Send: N146 G3 X88.515 Y178.243 I4.683 J-2.591 E25.83727*79
| Recv: echo:Unknown command: "4 G3 X89.456 Y182.555 I4.561 J-2.293 E25.68956"
| Recv: ok

Try with another, better USB cable: ferrite beads, thick wires, good shielding, as short as possible.

1 Like

I just switched my really short Western digital cable in place of the one currently installed. After a full reboot, the print is still blobby with the first layer running into the blob. I'm uploading a new system bundle.
octoprint-systeminfo-20211003161609.zip (40.7 KB)

I was using a number of plugins, Arc-Welder, Filament sensor simplified, IP on connect and a few others with the previous Creality V1.1.3 mainboard and stock Ender 3 V2 firmware. Just to see if anything would change, I uninstalled each, one at a time to see if any difference was made. After removing IP on connect and filament sensor simplified, there were no changes. After Arc-Welder was removed, the printer started working as it was intended with the OctoPi setup.
I'm guessing the original 8 bit board needed the Arc-welder plugin to print better curves and such. The 32 bit board must've been getting confused by the anti-stutter. I reinstalled the other plugins and have (so far) had no issues. I went back to my original USB cable just to see if it was making things worse and I determined it is not. I am surprised how many posts I see here and on Reddit about bad cables.
Thanks for your help, Ewald.
(I do have some snap over ferrite beads on order for the USB cable, just in case my wiring leaves room for EFI).

These pictures show the same stool printing with a brim and an Ender 3 bed level file from thingiverse. I am using Yellow TECBEARS PLA (shown with a black light).
These prints are after Arc-Welder was removed, I am still using all my other plugins.

1 Like

Arc-welder relies on curve print commands G2 & G3 for printing the arc. The support for these commands must be enabled, but in most stock firmware that's not the case.

You most likely had a custom firmware on 1.1.3 with G2/3 enabled.

Try compiling your own fw for your new board, or get an fw with these enabled.

I used the M115 command in terminal (as per the Arc Welder website) to see if ARC_SUPPORT was enabled, I did not get an UKNOWN COMMAND response. This tells me that ARC_SUPPORT is indeed available. However, I tried reinstalling it this afternoon just to see what would happen. Once again, the printer would draw the initial purge line on the right and then proceed to poop out a blob in the middle and start printing the first layer over the top of the blob.
I am in the belief, Arc-Welder borks my setup. I am currently not using it.

From your previous print sample, the one that failed, it looked like only the infill was printed, as the walls are all circles, and probably converted by ArcWelder into G2/G3.Hence my remark...

Maybe try a test: a g2 / g3 command from terminal to "draw" a circle in the air, just to confirm that printer is behaving correctly...

It sounds like you might be mixing up two things. The M115 command should report a number of capabilities, with 1s and 0s after them. If you don't see ARC_SUPPORT: 1 in that list then it is not enabled.

The other test, is sending a G2/G3 command to the printer and seeing if it reports unknown command, not combining the two tests.

G2 and G3 separate or G2/G3 say Unknown Command. Either way, not having Arc-Welder active or installed, solved my blob problem. Thanks Charlie for trying to straighten this out for me. Now If I can only figure out my PiCam issue.

1 Like

Watch where you position the pi and usb cable, and routing of Display cable..

On my E3Max I had real issues with the serial connection, and cray though it may appear, the ribbon cable to the display as to be routed over the top of the bottom extrusion not under it..

When I came across the fix posted I thought it was a wind up! The creality machines are terrible for screening and electromagnetic intemperance!

1 Like


Thanks, I'll try to keep up with my cable mess. I have completely changed the Ender 3 setup after a melted power supply connector ate my wiring. Using CR-10 standalone corner risers and some 5 mil plywood, I moved the power supply, Pi and silent mainboard under the printer. I used the plywood as the base by fitting it into the v-slot like a picture in a frame, then closed off the upper portion under the bed isolating it (the bed) from the electronics the same way. I'm currently printing 62mm tall panels to fill the side frames. I have some ferrite beads coming that may help with interference.
Thanks for your input.

I must apologise!

My comment was not directed at your issue, how i managed to post it in entirely the wrong place I have no idea other than my old eyes are getting worse at a rapid rate and another visit to the optician is due!

I did however have exactly the same issue as you on E3Max with 4.2.2 board and it was the same solution.. Clearly Arc is not supported in the firmware for this board :frowning: