All motors - X,Y,Z won't move after first attempt to print w/ Octoprint

What is the problem?

My Ender 3 V2, X, Y and Z axis won't move after my first attempt to print using Octoprint - although the motors make a small humming noise when called for.

After uploading a print file, I selected it and said print and after a second, I realized my printer wasn't doing anything. I checked the printer, it was frozen and I couldn't manually stop the print so, I turned it off.

Error message from Octoprint: WARNING - Received an error from the printer's firmware: Printer halted. kill() called!

What did you already try to solve it?

  1. Disconnected Raspberry Pi 4 4gb from my Ender 3 V2 printer and restarted the printer and tried to print the same thing from an SD card but it immediately got stuck again.

  2. Tested manually moving X, Y and Z from the LCD - none of them move but still make a small jolt and then a quiet humming noise when called upon.

  3. Auto-home locks up the system and needs to be re-booted after.

  4. Tested disabling and re-enabling steppers. - While disabled I am able to move all the axis but I am not after I try to use the move command on any axis.

  5. Checked my transmission ratios which were: X: 80, Y:80, Z:400, E:93

  6. All Max Speeds: Everything well above 0

  7. All Max Accelerations: Everything well above 0

  8. All Corner Speeds: all well above 0

  9. Did the reset option on my printer

  10. I tried updating to my firmware from 1.0.1 to 1.1.2 from Creality's website but that didn't work so I reverted back to 1.0.1.

  11. Re-connected to Octoprint and ran M503 and got this:

Send: M503
Recv: echo: G21 ; Units in mm (mm)
Recv: echo:Filament settings: Disabled
Recv: echo: M200 D1.75
Recv: echo: M200 D0
Recv: echo:Steps per unit:
Recv: echo: M92 X80.00 Y80.00 Z400.00 E93.00
Recv: echo:Maximum feedrates (units/s):
Recv: echo: M203 X500.00 Y500.00 Z5.00 E25.00
Recv: echo:Maximum Acceleration (units/s2):
Recv: echo: M201 X500.00 Y500.00 Z100.00 E1000.00
Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
Recv: echo: M204 P500.00 R1000.00 T1000.00
Recv: echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
Recv: echo: M205 B20000.00 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
Recv: echo:Home offset:
Recv: echo: M206 X0.00 Y0.00 Z0.00
Recv: echo:PID settings:
Recv: echo: M301 P28.72 I2.62 D78.81
Recv: echo: M304 P462.10 I85.47 D624.59
Recv: echo:Power-Loss Recovery:
Recv: echo: M413 S1
Recv: ok

(Comparing that to someone else's results I noticed my units in Celsius / Fahrenheit units clarifier was missing from that 2nd line towards the top but I'm not sure if that's a problem)

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Didn't try

Complete Logs

octoprint.log (121.4 KB)serial.log (93.4 KB)

Additional information about your setup

OctoPrint 1.5.3, OctoPi 0.18.0, Ender 3 V2, 1.0.1, Chrome, Windows 10 Pro, Webcam

Are you also able to move the Z axis? just to be sure

I couldn't BUT the problem is solved! For some reason it was the firmware from Creality. I tried almost all Ender 3 v2 firmware versions from Creality with no resolve. A friend gave me a custom firmware and that fixed it.

So an update, my printer has been acting kind of strangely since starting to use this custom firmware. Occasionally, at the beginning of prints it just decides to draw diagonal lines across my bed as well as make the fan act funny like slowing way down and making strange noises - Even though my Ultimaker Cura settings haven't changed. I tried to go back to the Creality drivers and my original problem returned. So, I'm forced to use this somewhat janky setup with custom firmware. If anyone has any tips I'd be glad to hear them. I'm afraid of my fan motor dying or something being weird about the motor settings.

where did you get the custom firmware from?