All Octoprint Instances stopped working on 6 Pi's?

What is the problem?

I am running 6 instances of Octoprint to control 6 3-D printers at my job. I am a teacher. ALL instances are unable to be accessed via. IP, I never could access via. octoprint.local. I am using a ETH connection, which currently says its UP if I check the IP.

I cannot access logs because SSH is not working. Tried to use WinSCP via SSH.

What did you already try to solve it?

Reinstalled Octoprint on one pi, tried to SSH, however I got an error message saying "network couldn't be accessed"

Have you tried running in safe mode?

No. I cannot connect.

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I cannot access the pi web interface or SSH.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am trying to access on chrome, windows 10 and my phone via IP.

When I look at the ETH0 it states its UP. I cannot access via wifi at work, WPA-2 network makes it too difficult.

So you can see that the Pi is connected to the network, but can't access it?

Have you spoken to whoever is running the network? It sounds as if they may have turned on some sort of isolation mode - it's a fairly standard security feature that doesn't allow devices to access each other on the network, only the internet. Prevents one 'infected' device from going after the rest of them. They may be able to exclude your OctoPrint instances or something.

The IT is...not too helpful at my job / takes weeks to get to my questions.

I mean this was working Friday and all of a sudden is not working. Do you think there would be any telltale signs if IT messed around with them?

Do you think even if I changed IP addresses it would still be affected, since I did give the pi a new Ip today, but still doesnt work..

I don't know enough about networking to help really to try and figure it out. I just got the feeling like something might have changed at the network level that meant you couldn't access any of them anymore suddenly.

If you can connect up a HDMI screen & a keyboard to one of them, you might be able to check if it has an internet connection.

A new IP will not help. The routers are set up by MAC address. Someone in IT probably locked out the MAC addresses of the Pi's for some reason and now they are no longer allowed to communicate. Is the IP address on the pi a 169.x.x.x? If so it is not even communicating with the networks DHCP server to provide it a proper IP for the subnet

Im a fool. I forgot layer 1 != layer 2. I saw my eth were UP (im connected via switch) and my switch wasnt on the network.

Another problem however 2 pi's now only have IPV6 addresses, I see no regular IP's. How do I fix that?

.local addresses require that 1) the router provide them and 2) software on the pc .
Also IT might block ip4 adresses fir several reasons, unexplained repeated internet access for example. They might assume its malware talking to a Command and Control server. You need to get IT involved. I know - I ran the firewall for a local collage for years.

Sounds like your schools' DHCP service is broken, because its not dishing out IPV4 addresses. I get that your IT support might be a challenge. If you can get a monitor and keyboard plugged into one of the pi's that might help because you can try forcing a dhcp client to acquire an IPV4 address. The command to do this is dhclient -4 -v, if you run this on a pi you shouldn't need to use sudo. And yes your IT support might have decided to arbitrarily block/deny because they don't recognise the devices and can't identify the owner - you!.

1 Like

part 2 -
If you have a spare Raspberry Pi, I'm assuming your switch is local to your printers here and not connected to the school backbone network - they could have even implemented VLANs without telling you. So how about running a local DNS on a Pi - then you have more control than relying on the school DHCP service. I routinely disable IPV6 on my raspberry pi's because I don't need it and I'm not going to run out of IPV4 addresses...

Part 3.... just a thought If you've reflashed your Pi's micro SD cards - have you changed the names of the Pi's? If they are all still raspberrypi, that will cause no end of confusion as multicast name lookups will break. Always good to try sudo arp -a from a command line prompt after trying to connect, you'll get a list of IP's and names and MAC addresses, something like this [which has been obfuscated]

demo-pisrv.mydomain.lan (192.168.10.5) at xx:xx:yy:77:2d:bb [ether] on ens33
demo-nas3.mydomain.lan (192.168.10.181) at xx:zz:nn:0a:95:bb [ether] on ens33
demo-printer1.mydomain.lan (192.168.10.38) at yy:zz:aa:3d:ab:bb [ether] on ens33
demo-printer2.mydomain.lan (192.168.10.183) at aa:bb:cc:8e:a7:bb [ether] on ens33
_gateway (192.168.10.254) at zz:zz:zz:5c:67:a9 [ether] on ens33
? (192.168.10.23) at on ens33

The last one is a failed connection, test done on an Ubuntu Virtual Machine