All time lapses append Failed at the end of filename

What is the problem?

When a print finishes, the time lapse filename is saved as XYZ-fail.mp4
My prints finish successfully so not sure why the filename is added. :slight_smile:

What did you already try to solve it?

Looked for default settings in the off chance there was a default filename appending

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (27.0 KB)

Additional information about your setup

Version 1.7.3
Creality Cr-10s running Marlin
Windows 10


Try safe mode.

1 Like

I have noticed this as well on my Ender 3 Max.
The print finishes as well as the time lapse photos are good and complete.
But all the file names end with "-fail".
I just accept that is the way it is, download it to my PC and rename it.
I will keep watching this post to see what causes it.

So, did you try safe mode?

1 Like

ah, of course safe mode would disable plugins to assist with troubleshooting, my bad.

Fixed the issue, now to turn them all back on one at a time to find the culprit.

So looks like it's one of the third party plugins we are using. Perhaps we can compare to see if there's any common ones we both use to start troubleshooting?

Try to disable OctoEverywhere!

Looks like TP-Link Smartplug is the culprit.
Could be the M81 ; turn off leds line I have in the gcode so I moved it to the before serial connection to printer is closed. I will report back with results

No difference, still gave me the fail in the file name.. Guess I'll just rename manually :stuck_out_tongue:

So I just got a notification from Octoeverywhere saying the print failed @ 99%...Reason : error (super helpful)

I would assume this is the reason behind things..The print is actually successful but it looks like it stays at 99%...odd

1 Like

I am also using TP-Link Smartplug so we have that in common.
I have it set to turn off the printer once the nozzle temp reaches 40c.
I do not use Octoeverywhere.

1 Like

I think tp-link is definitely the culprit. Octoeverywhere is simply sending a notification and since it’s classed as failed reports as such. I had all plugins on apart from tp-link and it didn’t give me the fail. So it’s either the tp-link plug-in or the gcode we’ve added to trigger it. As a side note I’m only using the smart plug to power lights on and off and not the printer.

So I solved the issue. For some reason I thought putting the M80 and M81 commands into my actual slicer GCode would be helpful, thinking since I used a 3rd part software to slice it would make sense. For some reason I had it in my head that I could slice in Octopi....anyway.
As soon as I took those back out and made sure I had the M80 ; turn on leds in the Before print job starts Gcode Script and M81; turn off leds in the After print job completes section it was all good.

The only issue I have now is with a new plug I have setup the 3d printer itself. I was hoping I could hit print tur turn it on and start printing etc, but catch 22. You need to be connected to the printer to start a print job :slight_smile: more -failed appended to timelapses.

My M81 (turn off TP-Link command) is in my Cura slicer program V4.13.1.
Preferences > Printers > Machine Settings > End G-Code > M81...

I haven't tried a timelapse in a while, perhaps the newer version has fixed this failed naming problem. I will try it again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.