Android devices crash my Octoprint

#1

I installed Octoprint and have not connected it to the printer yet because after getting it all set up with the camera I can access and view from any desktop/laptop however when I connect with an Android tablet or Android phone through chrome or the app I purchased it will either crash the pi immediately or after a few minutes. I thought maybe it was the camera crashing it so I tried with only the pi and still crashes. The only way to get back online is to unplug power and plug back in. I install updates every time I am prompted in hopes of one of them fixing the issue but so far no luck. Is this a known issue or is there something I can do to fix it? I tried searching the forum but did not see anything similar. Thanks

#2

watch the logs, either from your pi (connected to a screen) or from a computer that is ssh'ed in. If you use tail -f you can see what happens right before the pi crashes- if that's what is actually crashing.

#3

Just set up my Pi 3 b+ on MP Select Plus with Pi camera and all works well together. The video feed takes a few seconds to catch up to real time, but that's not the problem. I want to see the video on my Galaxy Note 9, but the android app keeps saying I have the wrong URL. How do I fix this? Also, just trying it at home and everything is on my Comcast home network.
Thanks.

#4

Wait, wrong URL, or "crashing Octoprint"? Those are two completely different things.

Are you trying to connect to octopi.local or to an IP?

1 Like
#5

Uhhm - @tedder42 - there are two different users for two different issues...

#6

ha. I went to the school for kids who couldn't read good.

#7

@Rocky_Gray Try http://octopi.local:8080/?action=stream but the phone has to be connected to your local wi-fi zone. If that doesn't work, try substituting the IP address for the octopi.local part.

1 Like
#8

Dear Guru, Thanks So Much! I changed the name to the IP address in the line you sent me and BAM! there it was. Only thing is it is upside down. Let me check settings....
Thanks, again.

#9
sudo nano /boot/config.txt
# Add this
display_rotate=2