Anet ET4 Marlin Connection issues

What is the problem?

Im getting this error few minutes after print starts .
"Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves."

What did you already try to solve it?

I have tried most of the website solutions like a shorter cable, tape on the connection, etc...

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

Not

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Attached the logs

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Anet ET4 with Marlin, It didn't work with original firmware also.
octoprint-logs.zip (816.4 KB)

looking at your Serial log, there is something extra on the end of most of your commands. *nn(n)
Not sure what this is but it seems to be confusing the printer.
For example:


2024-01-22 16:08:04,494 - Recv: ok N603 P0 B3
2024-01-22 16:08:04,503 - Send: N604 G1 X133.8 Y131.688 E.06511*95
2024-01-22 16:08:04,516 - Recv: echo:Unknown command: "95"
2024-01-22 16:08:04,522 - Recv: ok P0 B3
2024-01-22 16:08:04,531 - Send: N605 G1 X133.075 Y132.034 E.04868*87
2024-01-22 16:08:04,555 - Recv: Error:Line Number is not Last Line Number+1, Last Line: 603
2024-01-22 16:08:04,572 - Recv: Resend: 604
2024-01-22 16:08:04,581 - Recv: ok

When I look at the send commands on my printers connected to OctoPrint, I see the same added *nnn
I am not entirely sure what it is. Maybe a checksum or something that OctoPrint is adding. It's not in the gCode files. Maybe another person here can explain what that is exactly. Either way, looks like your printer is not ignoring it or using it properly and seems to think it sometimes is a command.

This seems to cause a knock on effect that at some point your printer just stops reporting temperature data.

I know this is not a solution but might help you get to one.

The added *nn is a checksum and is usually 2 digits long

https://reprap.org/wiki/G-code#Checking

2 Likes

I found the issue and it was an hardware problem.
The VCC and GND of the USB port didnt have enough voltage and fault ground. I used a 24V to 5V stepdown and weld to the USB. VCC and ground terminals and problem fixed. I see a lot of people with similar issues here on ET4 and other printers. They may facing the same issues. Thanks for the comments.

Regards,

Cesar