Anonymous usage setup


#1

What is the problem?
I just updated including the anonymous usage tracker. The setup will not move past the stupidly MANDATORY anonymous usage setup page regardless of what I choose.
What did you already try to solve it?
Restarted the Pi - it just goes to the anonymous usage page again and refuses to move forward. Chrome, Firefox, Opera, Edge - makes no difference. Incognito made - no difference.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Whatever the newest update is - I can't see shit because of the anonymous usage setup page


#2

You'r saying you can't opt out, or you can't take either path?

It's a release candidate, aka a 'beta'. Please assume good faith.


#3

He is saying that the popup screen that you have to opt into or out of is completely broken, no matter what you try and click or click finish it always says that you did not make a choice and to please chose. So now we cannot update or anything.

How do you manually disable this addon so that I can get past it?


#4

Don't use the release candidate, use the production version.


#5

good advice how do i go backwards from putty then? Or do i have to re-install completely?


#6

Here you go:


#7

is there a txt or script file i can edit to set this parameter ?


#8

Go to settings->octoprint->software update->config (the wrench at the upper right). Change release channel to stable. That's the default, which is why there's a warning alongside the parameter.


#9

i cant get there, the mandatory popup for the Anonymous usage setup wont go away.

I just reverted back to 1.3.9.

At this point I would not suggest using the new RC1, octoprint is not usable if the popup wont go away.


#10

I'm guessing that a JavaScript error of some kind is being thrown. It would be good to know what this is so that it can be recreated.

Developer's Console in the browser, look for errors


#11

Right, you have to revert and then change your release channel (look up a couple of posts where I linked to that).

That's the risk of using early releases! I don't know why it works for some and not others, but it'll get found and fixed.


#12

Sure I understand it is a beta, I was just asking if there was a known work around. This was the first post I saw with the same issue so I was adding on :slight_smile:


#13

mkhemi, aside from helping with the JS console above, are you pressing enable (or disable) and then next? Or are you expecting that 'enable' will take you to the next screen?


#14

Just tested new installs against these:

  • OSX Chrome v70
  • OSX Firefox v57
  • OSX Firefox v63

I also tried combinations of user auth, no user auth, enabled tracking, disabled tracking. All of these worked. :woman_shrugging:


#15

So by default the opt in was highlighted, clicking the opt in or out then finish just brought up an error that a choice had to be made.


#16

What OS/browser are you using?


#17

same thing happened to me, only javascript error was with the custombackground plugin, I thought it was just me being me that broke it (I sort of break octoprint a lot).


#18

What OS/browser are you using?


#19

chrome on windows 10, but I got it working with the RC on the same browser. I rolled back to 1.3.9, that was also broken due to a somehow now broken config file, manually fixed that, upgrade back to the RC and it works. So I think my version of the issue was due to a plugin, that was removed, that then broke the config, that then needed manual repair. Like I said, I tend to break octoprint a lot :slight_smile:


#20

I would prefer to be able to figure out what is causing this, but I can't unless someone able to reproduce this shares their octoprint.log and also the JS error console with me.

And so far none of the three people that aren't @PythonAteMyPerl who have run into this have done this. This is not going to get fixed that way.