Another WiFi Connectivity Question - faulty Pi?

What is the problem?
Pi 3 B+ will not connect to WiFi. I have detached the Pi from my printer and can connect to it in my home office using ethernet. I can run OctoPrint normally from my Windows PC, but as soon as I unplug the ethernet cable...nothing. The Pi will not connect to WiFi even after a reboot.

My child took a Google Home speaker with us on vacation recently and in order to get it to work at the rented house, changed our home network to the provided WiFi. This knocked everything back home off of WiFi. When we returned and renamed the Home network, I had to manually reconnect every device even though we used the exact same SSID and Password.

Our SSID has both a comma and three dots at the end...but my Pi with OctoPrint has worked fine since early 2019.

What did you already try to solve it?
Everything I have read in this and other forums.
Reinstalled using Raspberry Pi Imager
Reflashed to mSD Card
Installed using both methods on two different mSD cards.
Edited the "supplicant" file using Notepad++
Replaced power supply
Moved Google WiFi access point closer to printer
SSH into Pi over ethernet to update settings, run tests, etc. when I run a wlan0 test, nothing is ever found.
Octopi does not show up as a connected device in my Google WiFi app
Is it possible that the WiFi on the Pi is dead?

Logs (syslog, dmesg, ... no logs, no support) (88.0 KB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

Try sudo ifconfig wlan0 up
And see if you can see wlan0
Also make sure the country code didn't get changed

Country code is correct, I just checked the "supplicant" file to be sure. That suggested command doesn't do anything but take me back to the command prompt. But ifconfig gets me this:
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 2600:1702:3f10:36e0::736 prefixlen 128 scopeid 0x0
inet6 fe80::c902:7fcf:3fe2:9e5c prefixlen 64 scopeid 0x20
inet6 2600:1702:3f10:36e0:1694:f5c3:3833:d930 prefixlen 64 scopeid 0x0
ether b8:27:eb:ee:25:76 txqueuelen 1000 (Ethernet)
RX packets 63560 bytes 6423778 (6.1 MiB)
RX errors 0 dropped 2 overruns 0 frame 0
TX packets 10277 bytes 6968963 (6.6 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 2222 bytes 9323354 (8.8 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2222 bytes 9323354 (8.8 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:bb:70:23 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

And iwconfig gets me this:
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on

Additional results based on another thread's troubleshooting suggestion:

While I'd still like to fix the WiFi if it is fixable, and welcome any suggestions of what to try next, I did come up with a workaround. I moved one of our Google WiFi access points to the utility room next to the printer and connected the RPi to it via ethernet cable. So I can at least connect to and run Octoprint from my office again.

Have you tried
sudo raspi-config
Choose 1 System Options, then S1 Wireless Lan to re-enter the WiFi parameters.

I did indeed try that during my troubleshooting, and did so again today for good measure. Same results, no WiFi, but I can connect and run Octoprint via ethernet (plugged in to a Google WiFi puck). Thank you for the suggestion.

I would try an official version of Raspberry Pi OS (on a separate microSD card). If you can't get WiFi to work on that version either, then you may have faulty hardware.

Great idea! I'm able to connect via ethernet to the Raspberry Pi after installing the OS on a different card, but alas - still no WiFi. So while the results aren't great, I appreciate the suggestion. I'm going to chalk this up to bad hardware and keep the Google WiFi puck near the printer. Maybe I'll replace the RPi down the road when inventory has returned.

Thanks again.

You might be able to try buying a wifi dongle (USB), if you wanted to try fixing the issue without buying a new Raspberry Pi. I am not sure how the performance would rate, and you probably would want to completely disable the onboard wifi (I believe this is doable), but it might be a cheaper solution. Obviously just leaving it alone with a cable works just fine if you don't fancy it!

One thing to check is to make sure you only have the SSID set for a unique name of a 2.4g network. If its the same name as a 5g network it won't work, its best to set up a separate 2.4g. or just turn 5g off I the router to try it,

Unfortunately Google WiFi does not allow that, their system uses both bands with the same name for each and per their support page, the individual devices decide which band they connect to. The same support page also says that Google WiFi's "Band Steering" feature helps devices connect to the right band, maybe it's not letting the RPi connect to the 2.4g band. So my hands are tied unless I turn the WiFi back on at my AT&T UVerse router and activate the 2.4g band with a new name. I'm functioning fine with the current "fix," so will probably leave it as is. Thanks for the tip!