Any way to set the timelapse Z-hop height setting via gcode file?


#1

I use the regular timelapse in OctoPrint, and it generally works great. However, depending on which filament I print with, it may have different z-hop distances, and I don't always remember to change that in OctoPrint, leading to bad timelapses.

In my slicer (Slic3r PE) I have profiles for each filament. Is there any way to have the slicer add some sort of command at start of the gcode file to set this parameter in OctoPrint? So that I can just add it once to each profile and not worry about switching manually.

Thanks.


#2

Already tried Octolapse? There you can set the z-hop height.


#3

In the regular timelapse I can set it too. But it changes. For example, I use a z-hop of 0.4mm for PLA, but no z-hop for PETG.