Anycubic I3 Mega - temperature drops while printing


#1

Hi,

I was referred to this forum with my problem. Installation and connection of Octoprint (Version 1.3.6) to Anycubic I3 Mega (Version 3, 8bit Board, frimware 1.1.0) worked w/o problems. Also uploading of gcode files and start printing is ok. After a while (> 20 minutes) the temperature of extruder and bed drops suddenly. Console just shows that cold extrusion was prevented, but I guess this is just a reaction to the temperature drop. I never had such problems while printing from SD. With octoprint all attempts failed for the same reason. I have no idea what triggers the printer to reduce both temperatures.

I haven't found a similar issue in the issue list yet. Any idea or even advice how to solve this issue? As the printer works perfectly in stand-alone mode I do not see the problem related with the hardware. For me it seems something in Octoprint forces the printer lower the temparature.

Thanks in advance, Thomas


#2

Hi Thomas, any news on your problem? Got the same issue here.

I tried a different power supply (2.5A) for the Pi but problem remains. I now go for a 3A PSU, ´cause I red about, that this may be a problem of non-consistent power. I will see...

Apx after 45 min, the temp of the hotend drops from 205°C to 170°C, goes up again nearly to 220°C followed by next drop below 180°C and again and again...
Rising temp from 205°C to, let´s say 215°C only gives effect, that drops are "only" down to 180°C but they still repeat.

Would be nice, if you git any news on this issue. I will report, if the new PSU gives an effect.

Lee


#3

I'd be very surprised if the PSU for the Pi would make a difference here. It's the job of the printer or rather its firmware to maintain temperature, all OctoPrint does in that scenario is tell it "hey, please heat to X degrees, thanks". I'd rather look into the printer's PSU, its temperature calibration, PID tuning etc.


#4

u´r right and that was I thought too but I was told, that an inconsistent power supply of the Pi can affect silly things.

By the way: connected to my Tevo Tarantula or BW printers, theres is no problem with this. They maintain temp for hours within +/- 1°C...

So this is worth a try if there are no more ideas... The i3 maintains temp as well, when printing from SD


#5

So. I got the "original" Pi 3 PSU - no effect. Temp drops still remain after apx. 45 Min.

Made another testprint with same file but from SD Card (Pi turned of) - no problem. Temp stays stable around 205°C.

So this maybe a communication bug between Octoprint and Anycubic i3 mega...


#6

I suggest you approach Anycubic about this then. Considering that temperature control is completely the responsibility of the firmware on the printer, if it's not able to hold temperature when a serial host is connected, but it is able to hold temperature when not, something's broken inside that firmware. Wouldn't be the only thing broken about it either.