Anycubic predator connection problem

I ask for help.
I'm sorry I'm new.
i have an anycubic Predator printer connected to raspberry PI 4 Model B 4GB.
I have connection problems, once connected after a short time it freezes and disconnects.
I upload the results logs hope you can help me.
ps. the printer with sd works perfectly.
Thanks in advance

plugin_PrintTimeGenius_engine.log (45.3 KB)

octoprint.log (889.8 KB)

What is the problem?


What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hi :slight_smile:

Let's start with the easiest thing - did you try other usb cables?

yes I also tried the cable I use with another raspberry connected to an Anet 10

Did the other cable work a bit better?
An error at line 23 is pretty early so I guess there is a bigger problem.

If it was as bad as the other cable there could be something nearby that emits emi like a microwave, a refrigerator or a fluorescent light.

right next to the predator I have the anet E 10 and it works perfectly.
if you see from the photos I have attached there is a window that tells me "firmware broken" ... what can it be?

all the cables i tried work with the anet perfectly but give this problem with the predator ...

Some users reported that the display cable was causing similar problems.

Could be worth a try

serial (4).log (15,6 KB) octoprint (4).log (632,0 KB)

Good morning...
I formatted and restored the rasberry from scratch by adding some plugins needed to make the printer turn on ... doing some printing tests at the moment the problem no longer arises ... it makes me think that one or more plugins installed previously created me the problem ... as soon as I can I try to reinstall them in order to understand which plugin gave me the problem and if I find it I publish it so as to understand how to fix the error ...
I think the problem is partially solved ..

1 Like

this morning I performed a print with gcode sliced ​​with simplify3d of 4h and I had no problem .....
now I loaded a gcode sliced ​​with "cura" and the problem recurs ... I blamed some plugins but I think it's something in the gcode created by "cura" .. can you help me?

Which version of cura are you using?

version 4.8.0

that's good. an older version of cura had a bug which caused stuttering and other problems.
Maybe cura uses higher speed settings than simplify3d? :man_shrugging:

I'm a bit out of ideas here sorry.
I would still try it with a better cable - even if your other cables work with the anet.
Some mainboards or more sensitive when it comes to emi than others.

I'm using a cable with two ferrite beads for my printer.

problem solved .... I'm a little ashamed of how trivial it is ... it was a comma "," instead of a period "." in the initial setting of the gcode that I had entered or and the Z-OFFSET ....