Anycubic Vyper FW kill msg after sending this gcode

What is the problem?

I have been printing now for about a month with no problem. have Octoprint setupon a PI.
I have sliced two hairpins for my wife and both printing from Octoprint have gotten kill() msg from the
send: n3130 g1 f3000 x131.361 y133.712 e116.67641*48
This is the line in gcode that was sent from one of the two prints.

I have printed one of these fine before from teh SD card and am going to copy the gcode to sd and try it from there.

I have no idea about gcode commands so do not knwo how to parse the above.

What did you already try to solve it?

tried a different print than the two that fail. Worked fine. Will also try to print from sd card... as one of the prints worked from sd card before.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Attached (2.1 MB)

Additional information about your setup

OctoPrint version 0.18.0
Anycubic Vyper FW 2.4.5

Just tried to print same gcode from SD came out perfect. Will try again from octoprint ..

It's not said that the error was/is issued by the last line before the error message.
That line also looks fine.

The same also applies for the second occurrence of the error in the log.

2023-03-03 13:17:39,575 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Printer halted. kill() called!
| Last lines in terminal:
| Recv: ok
| Send: N22561 G0 X123.3 Y124.07*25
| Recv: ok
| Send: N22562 G0 X124.383 Y124.174*35
| Recv: ok
| Send: N22563 G0 X124.702 Y126.345*45
| Recv: ok
| Send: N22564 G1 F1500 E1702.62619*56
| Recv: ok
| Send: N22565 G0 F7200 X124.501 Y126.671*75
| Recv: ok
| Send: N22566 G1 F3600 X124.567 Y127.001 E1702.63179*60
| Recv: ok
| Send: N22567 G1 X124.233 Y129.951 E1702.68116*88
| Recv: ok
| Send: N22568 G1 F3779.5 X124.07 Y130.636 E1702.69231*20
| Recv:  T:200.16 /200.00 B:59.97 /60.00 @:72 B@:61
| Recv: ok
| Send: N22569 G1 F4044.9 X123.598 Y132.853 E1702.72586*45
| Recv: Error:Printer halted. kill() called!

Some firmware is a bit thrifty with their comments on error messages.
Regarding the last temperature message, it is not a thermal runaway.

There is something going on with that printer.

You may share the complete issuing gcode file in your next post. You may zip it.

Can't seem to reproduce this now..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.