Arandr is missing from OctoPi?

Hy there,
i am tinkering away for a few days now, setting up Octoprint after a complete crash.
In that endeavor i also tried to install it onto a complete Raspian Image, which works, but is (as you can imagine) clunky. So back to OctoPi via imager. I also installed the desktop via script. And here comes my problem: the screen configuration tool from the complete install of Raspian is missing. But this let me rotate my screen with ease! Without it i am struggling, having tried different methods i found online. Sure, i could fight through that and try to get it to work somehow, but it would be so much easier if i could install that tool instead. It seems that it is kscreen i am missing here, but after installing that, the option in the system preferences didn't show up either. (After the install and reboot, the raspi started with complete blue screen and full blowing fan [which i could not get to work beforehand under KDE so reliefes me that it actually will work some time in the futur!] SSH into it, restarted, desktop came up normally)
Can someone make any sense of this? And why is kscreen not part of the desktop installer from the start?
Thank you in advance

Ok, so more searching an testing brought me to the conclusion, that it is not kscreen that is missing, but a Randr GUI. This could be ARandr, wich actually produces a window like the one in the Raspian Image, but i can not change anything, all options are greyed. And it asks me for my password, so it is asking for higher rights here. I am at a loss. I can not make sense of this anymore.

Does xrandr not work?

no, not if you mean as terminal command like
To make things a little more clear, i use a 5" Monitor via HDMI

Ok, got it working manualy via the method discribed here:Inverting an HDMI display on the Raspberry Pi 4B