Arc Welder Plugin update check fails

What is the problem?

When checking for updates, Arc Welder plugin is throwing the following errors and states Unknown error while checking for update. please check the logs.

What did you already try to solve it?

Uninstalled and re-installed to see if that would work, it looks normal until you check for updates and then goes back to the previous. Checked logs and looks like something isn't supplying the proper info from the plugin

Have you tried running in safe mode and if so did it solve the issue?

Can't run it in safe mode to see if that helps as then you have no plugins

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (66.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.198 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 915714048
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.2.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.0

That's probably an issue with @FormerLurker's implementation of the release channels that changed in OctoPrint 1.5.0. He does have a development branch on his repo that he's looking for testers for. You can install it by copying/pasting the URL below into Plugin Manager > Get More > ...from URL. Not sure if it changes his update check routine, but will get you to the latest development version.

I just checked his code, and that version does modify the update checks to use the 1.5.0 methods, so just installing that development version should get you squared away and I'm sure @FormerLurker would like the additional feedback.

I'm getting the same thing with the dev release you linked

Get BlueMail for Android

Just got this working yesterday. Use this link:

Install in the plugin manager as usual.

Oh, and let me know if it works now please :slight_smile:

I will drop a message here when I push the RC, which will be soon, so you can let me know if the update pops up.

I have 1.0.1rc1.dev2+u.2a95fab installed, which release channel should we set Arc Welder to?

If it's set to Stable, will an update actually downgrade the plugin?

Yes, I'm pretty sure it will. At least, when I was first testing this feature that's how it worked if I remember, a couple of months ago.

The "Check for update now" button says everything is up-to-date regardless of which release channel is selected. I guess I should get brave and try "Update all"...

Maybe I should find a spare SD card and make a backup first :grinning:

Make sure you don't have rate limiting issues, it's 60 requests/hour, each plugin is one request (and this includes any device on the network).

"Update all" does exactly what "Check for update now" does, everything is up-to-date regardless of which release channel is selected. I guess this isn't the way to go backwards :wink:

The ball is in @FormerLurker's court now...

Have you tried 'force check for update' too, since that clears the cache and hits every github repo again. Too many times and you definitely will run into rate limiting.

Yes, I tried that too. I think the bottom line is that OctoPrint's Software Update doesn't go backwards, i.e. the check is "greater than or equal to" as opposed to just "equal to".

1 Like


Yes, I tried that too. I think the bottom line is that OctoPrint's Software Update doesn't go backwards, i.e. the check is "greater than or equal to" as opposed to just "equal to".

How can that be then given the reported version number:

Either this is an Octoprint version compare issue, or it's just picking the most recent version available given the repo branch criteria supplied to the software update plugin. In fact, I think this is the desired behavior. If one upgrades to a 'devel' branch, but wants to revert, picking the 'stable' branch should do exactly what it is doing now, IMHO.

Ok, so if I have the latest devel RC installed, but select the latest release channel as 'Stable' it will report the last stable release, but won't offer an 'update' button (didn't notice this before). It would be interesting if there were a 'Roll back' option, but that would require an "UP" and "DOWN" settings migration scheme that completes before the reinstall takes pplace, which we do not have to my knowledge.

This is exactly the behavior I'm seeing.

I'm guessing that if I want to go back to stable, I'll make sure the release channel is set to stable, uninstall, and install again.

I'm not planning to do this unless asked to do so as the latest devel release appears to be working fine.

Cool, I'm going to drop a new RC soon that includes some of the new arc-welder console issues and some fixes and other minor stuff (like the firmware checker). I'll try to remember to drop a line in here and you can let me know if the updater seems to be doing what we think it should.

That is working for me

1 Like

Ah, I was searching for an answer to this issue. But since I'm here I'd like to say this is a great plug in! I've been using it for several weeks and it hasn't ever (to my eyes) mucked-up any of my prints but yet compresses them. I print a lot of small stuff for model railroad project.


1 Like