Arducam Auto Focus camera

Camera model Arducam Auto Focus Pi Camera

What is the problem? Not entirely sure how to get auto focus to work

What did you already try to solve it? tried to enable with control.htm (modifying the octopi.txt file), tried to utilize v4l2 commands

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Additional information about your setup (OctoPrint version, OctoPi version, ...)

Purchased this camera:

with the hope that I could use the auto focus, or at least vary the focus on octopi, haven't had much success in figuring out how to integrate it. It seems many of the commands have either changed through revisions or are unavailable.

Nothing urgent as the stream is usable, but would love to be able to get focus a bit more acutely.

this might help

Thank you, I saw that and did try to run some of that, but I'll admit while I've touched on Linux before I really am very very new to this.


pip install pygame (I get -bash: pip: command not found, so I'm definitely missing a step.)

cd RaspberryPi/Motorized_Focus_Camera (didn't continue here as I don't have this folder in Octopi)

chmod +x


sudo reboot

you might find this useful
where's pip?

I found pip in ~/oprint/bin

BUT had to use ./pip to run it

Thank you, will give that a shot

There's also a plugin that hasn't been reviewed's my understanding that you only really have to run ./ once downloaded for it to work.

Well now that looks even easier and better. I can download the files easily, but can anyone give me some hints where the files/folders need to be?

Pretty sure the shell script can just be downloaded anywhere, made executable and run. I think it is basically just changing something in config.txt to be honest. The plugin can be installed in plugin manager using the download zip url in plugin manager, listed below for your convenience.

Well that was pretty easy, and the buttons have shown up so that's a good sign.

I am getting an error "unable to use SMBus/I2C" that I'm reading up on to try to figure out.

1 Like

stumbled across this, but searching through some terms to try to understand.

The plugin author is active in discord, not sure if it's the same @moof here.

Think he'll be offended if I create a new issue?

That's what they are there for I would assume.

I'll look into this and add better setup instructions. It may be a week or so, but I'll get to it.

Thank you. Nothing urgent as I do have a stream, but it would be nice to be a bit clearer.

Here's a question in the meanwhile, that I've not been able to find a clear answer to. Do I need anything else to get the camera to focus with your software? I noticed in some pictures there was two additional wires that went to the header pin on the raspberry pi, but it was never very clear if those were needed or not.

1 Like

the wires are for something else. All you’ll need is the ArduCam connected to the camera port with the flat cable.

1 Like

I'm getting the same "unable to use SMBus/I2C" in the Octoprint GUI as well. Not sure if there's perhaps a library missing that I should've installed? I'm a relatively new Pi/Github user, my husband is more experienced though and is also stumped. Still digging around to see what we can learn, but if you figure anything out @UltimaSE, please let me know.

Thanks for the tip about the extra sda/scl jumper wires @moof, I was thinking of trying them too (for the same reason - saw them connected in Arducam pics/videos) to see if they were necessary to resolve the error. Good to know they're not. :slight_smile: And thanks for creating this plugin, it looks like it'll be awesome once I figure out what I've messed up and can get it going properly :+1:t3:

Screen Shot 2020-07-05 at 4.06.35 pm

Ahh, cool - just found this same discussion on the Github issues board. Will monitor over there for updates.

Working beautifully. Thank you.