Arducam IMX519 16MP not connecting to Octoprint

RPI 4 B 4GB Board

Camera model

Arducam 16MP ITX519 sensor

What is the problem?

Will not connect to Octoprint monitoring.

What did you already try to solve it?

Attempted install of stable version, Nightly, klipper, and new camera stack (currently running) OS versions.
Followed all steps from arducam to install and run.
Ran update and upgrade on every version of the OS I tried.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (37.2 KB)

Additional information about your setup

OctoPrint version 1.9.2 , OctoPi version 1.0.0 , printer CR-6 Max, browser Firefox/Chrome, operating system Windows 10/11, I have scoured every corner of the internet and come up with no solution. I have full access to the webcam through VLC player using tcp/h264..... and verified the camera module does in fact work and the auto focus works fine there as well.

vcgencmd get_camera supported=1 detected=0, libcamera interfaces=1

libcamera-hello -v3
verbose: 3
info_text:#%frame (%fps fps) exp %exp ag %ag dg %dg
timeout: 5000
width: 0
height: 0
rawfull: 0
preview: default
qt-preview: 0
transform: identity
roi: all
metering: centre
exposure: normal
ev: 0
awb: auto
flush: false
wrap: 0
brightness: 0
contrast: 1
saturation: 1
sharpness: 1
framerate: 30
denoise: auto
viewfinder-width: 0
viewfinder-height: 0
tuning-file: (libcamera)
lores-width: 0
lores-height: 0
autofocus-range: normal
autofocus-speed: normal
autofocus-window: all
mode: unspecified
viewfinder-mode: unspecified
metadata-format: json
No connector ID specified. Choosing default from list:
Connector 32 (crtc 0): type 11, 0x0
Connector 42 (crtc 107): type 11, 1920x1080 (chosen)
Made DRM preview window
Opening camera...
[0:39:53.739879451] [1929] INFO Camera camera_manager.cpp:297 libcamera v0.0.0+4367-ad9428b4
[0:39:53.828405260] [1931] INFO RPI vc4.cpp:444 Registered camera /base/soc/i2c0mux/i2c@1/imx519@1a to Unicam device /dev/media3 and ISP device /dev/media0
[0:39:53.828472686] [1931] INFO RPI pipeline_base.cpp:1101 Using configuration file '/usr/share/libcamera/pipeline/rpi/vc4/rpi_apps.yaml'
Acquired camera /base/soc/i2c0mux/i2c@1/imx519@1a
Configuring viewfinder...
Viewfinder size chosen is 2328x1748
Final viewfinder size is 2328x1748
[0:39:53.829572058] [1929] INFO Camera camera.cpp:1033 configuring streams: (0) 2328x1748-YUV420
[0:39:53.830102966] [1931] INFO RPI vc4.cpp:572 Sensor: /base/soc/i2c0mux/i2c@1/imx519@1a - Selected sensor format: 2328x1748-SRGGB10_1X10 - Selected unicam format: 2328x1748-pRAA
Camera streams configured
Available controls:
FrameDurationLimits : [33333..127960799]
NoiseReductionMode : [0..4]
ScalerCrop : [(0, 0)/128x128..(0, 0)/4656x3496]
Sharpness : [0.000000..16.000000]
Contrast : [0.000000..32.000000]
Brightness : [-1.000000..1.000000]
AfSpeed : [0..1]
ExposureValue : [-8.000000..8.000000]
AeExposureMode : [0..3]
AeConstraintMode : [0..3]
AfPause : [0..2]
AeMeteringMode : [0..3]
AfMetering : [0..1]
LensPosition : [0.000000..32.000000]
AfTrigger : [0..1]
AwbMode : [0..7]
AfWindows : [(0, 0)/0x0..(65535, 65535)/65535x65535]
AwbEnable : [false..true]
AfMode : [0..2]
ColourGains : [0.000000..32.000000]
Saturation : [0.000000..32.000000]
AeEnable : [false..true]
AnalogueGain : [1.000000..16.000000]
AfRange : [0..2]
ExposureTime : [305..0]
Buffers allocated and mapped
Viewfinder setup complete
Requests created
Camera started!
Viewfinder frame 0 through 142
Closing Libcamera application(frames displayed 142, dropped 0)
Camera stopped!
Tearing down requests, buffers and configuration
Camera closed

sudo nano /boot/config.txt
GNU nano 5.4 /boot/config.txt

Enable host mode on the 2711 built-in XHCI USB controller.

This line should be removed if the legacy DWC2 controller is required

(e.g. for USB device mode) or if USB support is not required.




Run as fast as firmware / board allows



enable raspicam


sudo nano /boot/octopi.txt
GNU nano 5.4 /boot/octopi.txt

This enables network monitoring for wifi connections with a simple ping test.

If connection terminates by variable reasons system tries to restart the wifi>

The connection test is done every minute.

By default it is disabled (0 = off / 1 = on)

destination_host can be an ip address or a hostname (for hostname ensure dns >


Be sure to change this to match your network!



Support for different streamer types.

Available options:

mjpeg [default] - camera-streamer

hls - FFMPEG HLS streamer


libcamera-hello --list-cameras
Available cameras

0 : imx519 [4656x3496] (/base/soc/i2c0mux/i2c@1/imx519@1a)
Modes: 'SRGGB10_CSI2P' : 1280x720 [80.01 fps - (1048, 1042)/2560x1440 crop]
1920x1080 [60.05 fps - (408, 674)/3840x2160 crop]
2328x1748 [30.00 fps - (0, 0)/4656x3496 crop]
3840x2160 [18.00 fps - (408, 672)/3840x2160 crop]
4656x3496 [9.00 fps - (0, 0)/4656x3496 crop]

I thank you all in advance for the help.