🇺🇦 We stand with Ukraine! 🇺🇦

Arducam lagging in octoprint

Camera model arducam

What is the problem? in octoprint, the camera is very slow

What did you already try to solve it? no

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Additional information about your setup (OctoPrint version, OctoPi version, ...)

I guess with slow you mean low fps?
Which parameters did you configure in the octopi.txt?

Yes very low fps, like when i home my printer, it takes about 10-15 seconds for it to show in octoprint

I never configured anything.
I thought it would just work.

What changes do i need to make?

I can't help you with the delay but here are some posts on how to change your camera settings

hello, I have a arducam, and I am not sure what setting I need to change in octopi.txt
to make the camera run smooth? when I am viewing my camera from octoprint in a web browser, the refreshes very slow, it is hard for me to tell if the print is printing properly of if something is wrong.

I am using octoprint OctoPrint 1.5.3
OctoPi 0.18.0

with a raspberry pi 3

Why did you open a new thread?
I already answered you question?

change the framerate with this parameter
-fps or --framerate : set video framerate, default 1 frame/sec

this is what my octopi.txt file looks like, I do not know what I need to change.

# - raspi: only tries raspi cam

#

# Defaults to auto

#

camera="raspi"

### Additional options to supply to MJPG Streamer for the USB camera

#

# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration

# for available options

#

# Defaults to a resolution of 640x480 px and a framerate of 10 fps

#

#camera_usb_options="-r 640x480 -f 10"

### additional options to supply to MJPG Streamer for the RasPi Cam

#

# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration

# for available options

#

# Defaults to 10fps

#

camera_raspi_options="-x 1280 -y 720 -fps 20"

looks good

if the cam still runs with low fps try it in safe mode (some plugins change the cam settings).

How is the pi connected to your network? Wifi or ethernet? A bad/slow wifi connection can also cause framedrops.

Its connected to wifi.
My router is literally 5 feet away from my printer.

So the octopi.txt looks good?
There isn’t anything i need to change or add?

no. everything seems to be ok