Arducam not connecting to OctoPi

Camera model
Arducam Raspberry Pi Camera Module 8 Megapixel, 1080P IMX219 Camera

What is the problem?
I recently upgraded to a raspberry pi webcam coming from USB webcam. USB webcam works flawlessly. I either getting "connecting to webcam" or "webcam stream not loading" or something to that effect when connecting to Arducam IMX219.

What did you already try to solve it?
Initially changed octopi.txt to set default webcam to raspberry pi and uncommented. When doing this it would say something like "webcam stream not loading" instead of "connecting"

In the command line I tried "vcgencmd get_camera" and it outputs supported=1 detected=1.

I tried to use a different cable both 15cm and 50cm.

I even reflashed the sd card with a new OctoPi os, and doing all the above steps yields the same result.

I haven't tried anything with mjpg streamer, as I don't know any command line for this parameter. In fact I don't know much of the command line for OctoPi.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

octoprint.log (271.9 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)

OctoPrint 1.8.7
OctoPi 1.0.0
Raspberry Pi 4 Model B
Arducam IMX219
Ender 3 Pro

OctoPi 1.0.0 is based on Debian 11 (Bullseye) and most of the topics and how-tos are targeted towards OctoPi 0.18.0 (i.e. Debian 10 (Buster)).

There is an effort underway to replace the camera support on OctoPi 1.0.0 with newer stuff based on libcamera and camera-streamer, See for details.

I would strongly suggest that you download and flash the latest image posted in that topic. If you do an OctoPrint backup on your existing system (and download it), you can upload it to the new image and be back to where you are now.

If your camera still doesn't work, you will at least have the newer camera code and there are people watching the topic above that can hopefully help you get it working.

Thanks, I tried the image. No luck. I made a post over there.

Can you share a link to the webcam model?

The answer was there. I fixed it.

 Please modify the config.txt before using it:

sudo nano /boot/config.txt

add the line: dtoverlay=imx219

To override the automatic camera detection, Bullseye users will also need to delete the entry or change it to value 0.


update: camera_auto_detect=0

For Pi 0-3 bullseye users, you also need to enable glamor acceleration:

sudo raspi-config

Navigate to Advanced options——Glamor——enabled
1 Like

Following, Has anyone been able to connect imx219 to Octoprint? Appreciated

It looks like the person that opened this topic was able to, based on their last post.

1 Like

This worked for me with the Arducam IMX219, thanks!

1 Like