Arducam web stream not loading. (but raspistill works)

Camera model
Arducam 5mp OV5647 camera

What is the problem?

When I first started setting things up, the camera stream always gave me "The webcam server is currently not running" page. I tried some things, and got it to the point where it said "supported=1 detected=1, libcamera interfaces=0" instead of "supported=1 detected=0, libcamera interfaces=1". Now it detects the camera and shows me video when I run "raspistill -t 0", but still keeps giving me "The webcam server is currently not running" page.

What did you already try to solve it?

I forgot what I did at first, but I have tried reflashing octoprint and running "sudo vcgencmd start camera-streamer" (also tried restart).

Have you tried running in safe mode?

I don't know what safe mode is. I'm new to this.

Did running in safe mode solve the problem?


Additional information about your setup

I have the most recent version of the octopi with the new camera stack. My pi is connected to an ethernet cable.