Auto Boot to browser with an Adafruit screen 3.5

#1

Hi can some kind person point me in the right direction for the above.
I have been at it now for about a month and starting to loose it. I have done all the configuration one I can find on the internet but every time no luck. It's for a Raspberry pi 3+

Thanks

#2

I'm using the 2.8" version from Adafruit and talked about it here. Adafruit usually has great information about installing their own drivers for these. You'll need to chase their (multi-screen) adafruit-pitft.sh script which does a lot of the work.

You'll have to figure out what exactly you'd like to display on your screen first though. Do you want just a text console or do you want a GUI? You may then want to run the script in ~/scripts folder to install the Desktop (GUI), to run sudo raspi-config and get the Raspi to auto-boot into the GUI as the pi user. For the GUI, you'll need a microSD card larger than 4GB, for what it's worth.

#3

Thank for the reply but still no go with it.I have X3 pi's and X2 Adrafuit 3,5 screens and 1 7" pi screen and all no go when I try and put octoprint on with boot to browser just keep getting failed to install all the time. I could under stand one machine being down but not all 3.

#4

Is there any messages besides failed to install? That isn't an issue with octoprint, but sounds like there are required packages missing from the pi itself.

#5

Hi
Sorry for the late reply that's what I first thought I am missing something more probable me missing something out.
I am trying to get octoprint to boot to desktop with Octoprint start up strait away(boot to browser) . Do I need the desktop installed because it's not on light or just TouchUI installed or both? As I don't know if one is fighting the other.
Thanks
Organic

#6

Yes, install the Desktop (see ~/scripts). Run sudo raspi-config to make it auto-boot into the Desktop.

Next, you'd need to create a line in a file called ~/.bashrc with chromium-browser --kiosk localhost and install Chromium on your Raspi with sudo apt-get install -y chromium-browser.

If your LCD/TFT is in the correct orientation and you've installed everything as suggested, it should automatically boot into OctoPrint from a full-screen Chromium browser session. You may find that the touchscreen may or may not work; you'd then need to back up a step and calibrate that.

Connecting TouchUI to a Raspberry pi 7 inch touchscreen
#7

Thanks for the help I now have it booting up in TouchUI just that the calibration is now off by about 90 degree I have tried most of the help sites still no luck as of yet any ideas what I can do to correct it please.

Organic

1 Like
#8

Did you run Adafruit's script to setup your screen? This should have adjusted the touchscreen portion's orientation. Go through their website for setting up the model you purchased.

#9

Hi
Yes been through Adafruit's script the setup and all fine till touchUI starts up and the screen out about 90 Iam going to try it again in the morning but put different screen size in just to see what happens.

organic

#10

Hay pal I’m trying to create that line in with the command that you gave me but no matter how I type it in it tells me that no such file or directory, I must be typing something wrong

#11

Not sure which one we're talking about but I'll assume you meant the one to adjust your bash defaults. This is me doing a session with a Raspberry Pi. Ignore any dollar signs; they're there to let you know that this is a command prompt. Anything that's missing the prefix dollar sign is a response or content that you're supposed to type/add.

Useful nano hotkeys:

  • save is Ctl-o
  • exit is Ctl-x
$ nano ~/.bashrc
chromium-browser --kiosk localhost     # Add this as the last line and save/exit
#12

Ok this is what I got so far, what would be my next step?

#13

You typed the wrong character in the path to .bashrc. ~ (tilde), not ﹁

#14

Your right I didn’t notice that, my eye sight is going bad I guess :joy::joy:

#15

And of course, you have to save the file and exit with Ctl-o, Ctl-x

#16

Thanks I’m going to do this tonight