Auto-connect on server startup failure

What is the problem?

Can't get the Auto-connect function working, there seems to be a timing problem. Printer (Ender3 v2) has a little bit of startup time, when octoprint wants to connect the printer isn't fully started yet. 3~5 seconds after the auto-connect attempt, the port can be connected with manually.

What did you already try to solve it?

Changed port and baudrate to auto and hard values, did good amount of restarts and reboots -

Systeminfo Bundle (117.2 KB)


OctoPrint version 1.7.3, OctoPi version 0.17.0, printer Ender3 v2, firmware Marlin 2.0.1, browser Chrome, operating system running on Raspberry Pi 3 Model B Rev 1.2

A simple workaround: delay the start of the pi :slight_smile:

Add boot_delay to your config.txt

For example for a 5 seconds delay use


Thank you for answering, so quickly :slight_smile:

The Pi is always on, it sends PSU control command to start the printer, boot_delay sadly won't help me.

If there only was a delay for auto-connect or printer_startup delay, that would solve the whole problem.

There should be some settings in PSU control for that I suspect, for it to control connecting to a printer with some delays.

If the Pi is always on, then I don't think auto connect on startup is what you want - that would only happen once when you turn the Pi on?

I feel so dumb, literally tunnel vision. Thank you very much!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.