Automatic bed leveling starts upon print completion on Eryone ER20

What is the problem?

Immediately after printer reports job completion, Octoprint starts bed leveling automatically. As result still hot nozzle hits the object on the bed, melts parts of it and damages the print. If Octoprint is not connected to the printer then auto bed leveling does not happen, printer finishes the job as expected, nozzle goes into starting position. I have checked the GCODE post-print script setting, there is no custom defined.

What did you already try to solve it?

Checked "After print script" setting in the Printer > GCODE Scripts settings section. There is not script that could explain automatic bed leveling.

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

Have not been tried

Systeminfo Bundle

octoprint-systeminfo-20230122145300.zip (14.2 KB)

System bundle added

Additional information about your setup

Octoprint version: 1.8.6
OS: Linux (Amazon DeepLens Device)
Octoprint runs as as privileged docker container
Printer: Eryone ER20
Firmware: Marlin Marlin 2.0.5.3 (factory version)

Can you turn on your serial logger so we can see what a print output (comm) looks like.

2023-01-22 14:45:35,759 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

1 Like

Please also test in safe mode, otherwise we don't know if it's core OctoPrint or an issue with a misbehaving plugin...

Tested in safe mode. The issue has not been reproduced. I understand that the issue is then plugin's behavior. Bed level visualizer is the first suspect I try to disable. Any other idea would be appreciated.

My Bed Level Visualizer plugin would only send the configured commands if you press the update mesh button, or when switching to the tab with the Save Mesh option unchecked.

You also may check the end gcode in your slicer and here: OctoPrint Settings -> GCODE scripts -> After print job completes