Bed leveling returning funky results

What is the problem?

So a newbie here who could use some help. Installed a new SKR-Mini E3 V2.0 in my Creality Ender 5+ and now having leveling problems. I am having issues with the LCD which I found afterwards, isn't supported with this board; I have ordered a replacement that will work with it. In the meantime, I opted to use Octoprint, which has always been my preference anyway.

Everything works OK. I can home the extruder; move it in all three axis; on power up, the BLTouch does it power up routine; and when I do a bed level check using Bed Visualizer, it performs it's routine as usual.... the only problem is that the results are a plane at about a 30-degree angle. See the following screen shot.

I checked the build surface with a dial indicator, and it is pretty much spot on for being level. Prior to installing the new board, I never had any issues other than needing minor bed adjustments.

What did you already try to solve it?

Re-flashed the firmware using three different firmwares meant for the Ender 5+ with the BLTouch, one from BigTree, the board supplier, from Marlin and the last from Kersey Fabrication. All three yielded the same results

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Cannot run Bed Visualizer in safe mode, but the printer did operate and printed a flat first layer for my bed check (four corners and center)

Systeminfo Bundle (162.3 KB)


Additional information about your setup

OctoPrint 1.6.1
Python 3.7.3
OctoPi 0.18.0
Creality Ender 5+
Marlin 2.0 Modified for Ender5+ with BLTouch
Microsoft Edge running on Windows 10 build 21390.1
Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz 2.90 GHz 8 GB


look at the actual data coming back from your firmware and compare to the visualization.


Have a look at the scales x-y go from 0 to 300 z from -2 to 2. In other words the is a "skew" of almost 2mm in Z direction over 300 mm distance of X direction.

Is that right ? Move the head without ABL / G29 enabled or just by hand (with steppers disabled), and you'll notice if that is right.

If so adjust with bed levelling screws...

The bed is level, confirmed by a dial indicator. The deviation over the indicator was about +/- 0.04 mm, but all four corners where at the same level. I was also able to get a good calibration print in safe mode but unable in the normal mode. When I tried that printer started extruding well above the bed and immediately started closing the Z gap as it transverse on the x axis. Had I not been watching it and able to stop it immediately, it would have done some damage as it started to dig into the build plate.

I ran a debug log and have attached.
plugin_bedlevelvisualizer_debug (1).log (970 Bytes)
The numbers reported look to me like they are matching the visualization.

So I updated to the latest Marlin bug-fix and no longer have this issue. Not sure what the problem was, but it's working now.


@SafetyWiz, I am struggling to get bed leveling working on the same configuration (Ender 5+ with skr e3 mini v2) and am hoping you might have some pointers and/or would be willing to share your configuration headers for marlin 2