Bed visualizer: No visual Mesh! I'm Lost.... My second identical set up, one not working

Hi, so I have 2 Chirons, 2 Pi's, 2 complete set-ups.

One my home setup, Bed vis. works perfectly.
On my 2nd work setup, I do not get a visual mesh.

I am running the exact G-code on both, I thought it may have had something to do with my work printer.
I took the Pi home, and tried it on my home printer. Same result. Nothing, so I know it has to do with the pi/octoprint set up somewhere.

I have also tried 2 different probes.

I have tried all sorts of g-codes I have found online, some probe the bed, some don't.
The code that works at home for me is,

G28
G29 T

I have tried inserting @BEDLEVELVISUALIZER,

G28
@BEDLEVELVISUALIZER
G29 T
which also does not work.

Without using the @BEDLEVELVISUALIZER code, I get stuck on " Please wait, retrieving current mesh."

It is creating mesh data;

y Mesh z Height in:
mm
0 -2.330 -2.220 -2.190 -2.150 -2.270
100 -2.420 -2.240 -2.150 -2.110 -2.220
200 -2.460 -2.270 -2.160 -2.100 -2.260
300 -2.410 -2.300 -2.190 -2.160 -2.270
400 -2.420 -2.320 -2.330 -2.230 -2.300
x 0 100 200 300 400
x - Position
y - Position
Z Height: below offset / above offset


I have Save Mesh turned on, and have my timeout up to 3000. Tried with different values, did not make a difference.

I have updated the PiP in the Pi as well.


Here is the link to my log, I wasn't sure how to upload it here, so I put it on my drive and I was over the character limit on a post.

https://drive.google.com/file/d/1jdSJcM5QF2X0DQU-5aTHs532Is5SBlS2/view?usp=sharing

Any help is very much appreciated.

Thanks

Enable debug logging in the plugin's settings, restart OctoPrint and try the process again. Once complete if it still doesn't work please upload the plugin_bedlevelvisualizer._debug.log file from OctoPrint's logging section in settings. Also, please share a screenshot of all your settings. The correct gcode to use is the one in your second example.

G28
@BEDLEVELVISUALIZER
G29 T

Hi, here is the requested info.
I have also cleared Cache and temp files.

**

Log is attached to this post.

**


octoprint (1).log (251.1 KB)

Sorry for the multiple posts, could only add 1 image per post.

I need the plugin_bedlevelvisualizer_debug.log file. Also, not sure if it's related but looks like your loosing a connection to your printer.

2020-06-21 05:25:54,211 - octoprint.util.comm - INFO - Communication timeout while idle, trying to trigger response from printer.
2020-06-21 05:25:56,923 - octoprint.util.comm - ERROR - Unexpected error while reading from serial port
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 2823, in _readline
    ret = self._serial.readline()
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 4968, in readline
    c = self.read(1)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/serial/serialposix.py", line 501, in read
    'device reports readiness to read but returned no data '
SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)

I am back at work now with my second printer.
For some reason it is not producing a log file like it did last night..?

I have tried gcode with and without @BEDLEVELVISUALIZER

I have tried all USB ports on the Pi, 2 cables, 2 probes, etc.

I must be doing something wrong.

Is there a way to make an exact copy of my one known working SD card with Octoprint installed to another to eliminate a hardware issue in the Pi.

(Order is newest first below)

I also get this error sometimes, could just be a time out?

UPDATE @ jneilliii:

I was able to get a log, it doesn't show much:
plugin_bedlevelvisualizer_debug.log (554 Bytes)

Yep, that looks like the disconnect I was seeing in the log. Is the printer losing power? You can use the same software that you used to write the sd card with an octopi.img to create a backup of it, but I would just run a backup from within OctoPrint and a restore on the other. Or take a backup of a working one, re-flash the SD card with a fresh octopi image and restore your settings.

@jneilliii:
Ok, so I tried to do a backup, failed.

Started fresh on both SD cards, with a good format of cards.

-The only plugin I installed was Bed Vis.

-Set up the g code, and exact same problem, now on both of my Pi's,

-No power is being lost.

Still stuck on, " Please wait, retrieving current mesh."

This is the most current log it just gave me 2 minutes ago.
plugin_bedlevelvisualizer_debug (1).log (554 Bytes)

Does raberian have to be mounted to the SD as well as Octoprint?
Is there anything else I can try?

UPDATE: @jneilliii 2020-06-22T02:43:00Z
So I installed fresh again. I think one of my issues was mounting and updating through a USB hub.

When I use the code;

G28
G29 T

I get some sort of result, if I add @BEDLEVELVISUALIZER I do not get any result, but it is no longer hanging at the point of "Please wait, retrieving current mesh."

This screenshot is of the code without @BEDLEVELVISUALIZER, if I insert that code there is nothing on the grid.

plugin_bedlevelvisualizer_debug.log

[2020-06-22 03:25:52,202] DEBUG: mesh collection started
[2020-06-22 03:26:21,580] DEBUG:
[2020-06-22 03:26:26,754] DEBUG: X:-10.00 Y:0.00 Z:0.00 E:0.00 Count X: -800 Y:0 Z:0
[2020-06-22 03:26:26,765] DEBUG: ok
[2020-06-22 03:26:26,770] DEBUG: G29 Auto Bed Leveling
[2020-06-22 03:26:56,803] DEBUG:
[2020-06-22 03:27:26,835] DEBUG:
[2020-06-22 03:27:56,867] DEBUG:
[2020-06-22 03:28:26,900] DEBUG:
[2020-06-22 03:28:56,930] DEBUG:
[2020-06-22 03:29:05,583] DEBUG: Bilinear Leveling Grid:
[2020-06-22 03:29:05,590] DEBUG: 0 1 2 3 4
[2020-06-22 03:29:05,592] DEBUG: 0 -2.30 -2.20 -2.14 -2.14 -2.30
[2020-06-22 03:29:05,596] DEBUG: [u'-2.30', u'-2.20', u'-2.14', u'-2.14', u'-2.30']
[2020-06-22 03:29:05,600] DEBUG: 1 -2.38 -2.26 -2.11 -2.09 -2.25
[2020-06-22 03:29:05,601] DEBUG: [u'-2.38', u'-2.26', u'-2.11', u'-2.09', u'-2.25']
[2020-06-22 03:29:05,603] DEBUG: 2 -2.42 -2.30 -2.14 -2.09 -2.37
[2020-06-22 03:29:05,605] DEBUG: [u'-2.42', u'-2.30', u'-2.14', u'-2.09', u'-2.37']
[2020-06-22 03:29:05,607] DEBUG: 3 -2.37 -2.32 -2.17 -2.27 -2.35
[2020-06-22 03:29:05,608] DEBUG: [u'-2.37', u'-2.32', u'-2.17', u'-2.27', u'-2.35']
[2020-06-22 03:29:05,611] DEBUG: 4 -2.39 -2.39 -2.35 -2.33 -2.38
[2020-06-22 03:29:05,612] DEBUG: [u'-2.39', u'-2.39', u'-2.35', u'-2.33', u'-2.38']
[2020-06-22 03:29:05,614] DEBUG:
[2020-06-22 03:29:05,984] DEBUG: X:384.00 Y:393.00 Z:38.78 E:0.00 Count X: 30720 Y:39300 Z:14560
[2020-06-22 03:29:05,990] DEBUG: ok
[2020-06-22 03:29:05,992] DEBUG: {'z_min': 0, 'y_min': 0, 'x_max': 400.0, 'x_min': 0, 'type': 'rectangular', 'y_max': 400.0, 'z_max': 450.0}
[2020-06-22 03:29:05,992] DEBUG: stopping mesh collection
[2020-06-22 03:29:05,994] DEBUG: [[u'-2.30', u'-2.20', u'-2.14', u'-2.14', u'-2.30'], [u'-2.38', u'-2.26', u'-2.11', u'-2.09', u'-2.25'], [u'-2.42', u'-2.30', u'-2.14', u'-2.09', u'-2.37'], [u'-2.37', u'-2.32', u'-2.17', u'-2.27', u'-2.35'], [u'-2.39', u'-2.39', u'-2.35', u'-2.33', u'-2.38']]
[2020-06-22 03:30:44,400] DEBUG: mesh collection started
[2020-06-22 03:31:11,216] DEBUG: X:-10.00 Y:0.00 Z:0.00 E:0.00 Count X: -800 Y:0 Z:0
[2020-06-22 03:31:11,223] DEBUG: ok
[2020-06-22 03:31:11,234] DEBUG: G29 Auto Bed Leveling
[2020-06-22 03:31:41,268] DEBUG:
[2020-06-22 03:32:11,300] DEBUG:
[2020-06-22 03:32:41,332] DEBUG:
[2020-06-22 03:33:11,365] DEBUG:
[2020-06-22 03:33:41,397] DEBUG:
[2020-06-22 03:33:49,547] DEBUG: Bilinear Leveling Grid:
[2020-06-22 03:33:49,551] DEBUG: 0 1 2 3 4
[2020-06-22 03:33:49,556] DEBUG: 0 -2.32 -2.19 -2.12 -2.07 -2.19
[2020-06-22 03:33:49,558] DEBUG: [u'-2.32', u'-2.19', u'-2.12', u'-2.07', u'-2.19']
[2020-06-22 03:33:49,561] DEBUG: 1 -2.39 -2.18 -2.03 -2.02 -2.16
[2020-06-22 03:33:49,562] DEBUG: [u'-2.39', u'-2.18', u'-2.03', u'-2.02', u'-2.16']
[2020-06-22 03:33:49,565] DEBUG: 2 -2.45 -2.27 -2.05 -1.98 -2.20
[2020-06-22 03:33:49,566] DEBUG: [u'-2.45', u'-2.27', u'-2.05', u'-1.98', u'-2.20']
[2020-06-22 03:33:49,568] DEBUG: 3 -2.45 -2.27 -2.13 -2.16 -2.22
[2020-06-22 03:33:49,570] DEBUG: [u'-2.45', u'-2.27', u'-2.13', u'-2.16', u'-2.22']
[2020-06-22 03:33:49,572] DEBUG: 4 -2.44 -2.33 -2.23 -2.13 -2.15
[2020-06-22 03:33:49,573] DEBUG: [u'-2.44', u'-2.33', u'-2.23', u'-2.13', u'-2.15']
[2020-06-22 03:33:49,575] DEBUG:
[2020-06-22 03:33:49,943] DEBUG: X:384.00 Y:393.00 Z:38.55 E:0.00 Count X: 30720 Y:39300 Z:14560
[2020-06-22 03:33:49,946] DEBUG: ok
[2020-06-22 03:33:49,947] DEBUG: {'z_min': 0, 'y_min': 0, 'x_max': 400.0, 'x_min': 0, 'type': 'rectangular', 'y_max': 400.0, 'z_max': 450.0}
[2020-06-22 03:33:49,949] DEBUG: stopping mesh collection
[2020-06-22 03:33:49,952] DEBUG: [[u'-2.32', u'-2.19', u'-2.12', u'-2.07', u'-2.19'], [u'-2.39', u'-2.18', u'-2.03', u'-2.02', u'-2.16'], [u'-2.45', u'-2.27', u'-2.05', u'-1.98', u'-2.20'], [u'-2.45', u'-2.27', u'-2.13', u'-2.16', u'-2.22'], [u'-2.44', u'-2.33', u'-2.23', u'-2.13', u'-2.15']]

The mesh is outside the range if the graph (+/-2mm) use the option for relative z offsets.

@jneilliii
Thank you VERY MUCH for your help!
It is working great.

I think the main takeaway here is, do not flash or update your SD card through a USB hub.
As soon as I plugged directly into my computer, things started coming together.

1 Like

This got my new install finally working beyond 'retrieving current mesh' without the print head moving. Thanks for the tip.