(Beginner) struggling to connect camera

Camera model

Raspberry Pi High Quality Camera

What is the problem?

Control shows "Webcam stream not loaded" under either "Classic Webcam" or "Camera Streamer". If I hit Test alongside Stream URL under the Classic Webcam settings, I see a broken image placeholder (this is just more evidence that something is wrong with the URL; as mentioned below, I'm actually trying to use the new Camera Streamer setup rather than Classic Webcam).

What did you already try to solve it?

I switched to the new camera stack Octopi.
I confirmed that the camera is connected/working by taking an image using raspistill.
I looked inside libcamera.conf and don't see anything wrong.
I ran "sudo systemctl status camera-streamer.service" which suggests that the service is active, although I'm not certain because it says "active (exited)".
Under my Camera Streamer Control settings, the Webcam URL is (double-checked the IP/port).
I tried accessing the stream URL directly in Chrome/Firefox and it fails in those browsers too.

Have you tried running in safe mode?

No (don't think this is plugin related?)

Systeminfo Bundle

octoprint-systeminfo-20240204105149.zip (190.9 KB)

Additional information about your setup

OctoPrint: Version 1.9.3
OctoPi: Build 2023.10.09.154319 with "camera-streamer", based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.5
Printer: Prusa MK3S+

Thanks in advance for any help and apologies for anything confused or incorrect above (every aspect of this is brand new to me).

All the camera-streamer "main" service does is launch the available stream files that you have configured. The systemctl command you issued only shows the status of the parent service not the one you are really interested in.

From your logs I do not see that a child stream service has been launched by the main camera streamer service.

The command you want to issue instead is as follows...

sudo systemctl status camera-streamer-libcamera.service

From what I can see the RaspiCam is not showing up and the service is likely not running.

1 Like