πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Best way to find out what causes freezing when not in safety mode?

What is the problem?

Freezing of Octoprint when not in safety mode - happens while printing but also when idle

What did you already try to solve it?

checked the logs, checked if there is any throttling or under voltage or over temperature

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

yes

Systeminfo Bundle

octoprint-systeminfo-20220615150714.zip (371.2 KB)

WRITE HERE
Hi folks,

I have been working with Octoprint for more than two years now and print almost daily.

Recently I have again the problem that Octoprint freezes regularly. This happens both during printing and when idle. I already had this problem once a few months ago and I could fix it then only by after a complete reinstallation of Octoprint (without importing a backup). Then everything ran without problems for a long time.

After I gave my Ender 3 a firmware update last week, the same problem occurs again. However, I strongly doubt that the update is the trigger.
I have tried several adaptations, to baud rate, buffer size, in firmware and in Octoprint settings etc. and have watched the Serial.log and Octoprint.log. However, I simply cannot assign the cause.

Since everything works fine in security mode, it must obviously be one of the installed plugins. I have already rummaged through the various logs - but could not find anything so far.

What would be the best approach to get to the cause of the error?

In the attached system info bundle, I manually disconnected and reconnected the USB cable at 2022-06-15 07:41:02. At 08:15:47 I then started a print. At 08:28:09 Octoprint froze ... printing stopped. Only a complete restart of the Octoprint service helped.

Any ideas?

Additional information about your setup

Raspberry Pi 4 Model B Rev 1.2
env.python.pip: 21.3.1
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.last_safe_mode.date: 2022-06-15T11:11:11Z
octoprint.version: 1.8.1
printer.firmware: Marlin 2.0.9.3 (Jun 14 2022 08:42:44)
printer: Ender 3 Pro

Probably the simplest way (though time consuming) is to play with enabling & disabling plugins until you get to the one causing the problem.

You can do this efficiently by disabling half of the plugins, checking if the issue is present. If not, then you can enable half of the plugins you disabled. If it is present, then you disable another half of your plugins. You keep going with this until you find the plugin causing issues. It can work in just a couple of steps.

First you should turn off constantly DEBUG mode.

Your octoprint.log with DEBUG information:

grafik

And without:
grafik

About two thirds of the log are just DEBUG infos.
They use space, CPU time and can cause system lags.
They are used by the Devs to check their plugins and have no purpose for the usual run time.

Obviously the system runs fine in safe mode because the plugins don't produce DEBUG info entries.

Dear Ewald,

thanks for the tip - a good approach. However, I activated the logs only after the freezing occurred several times.

I have activated all loggings now also in security mode - without problems - except for the disk space consumption of course.

Dear Charlie,

these days I try it by activating each plugin one by one. But so far I haven't found the cause of the problem.

Today I was "live" when octoprint froze again.

Immediately after that I looked at the status in the command line and there was the error according to the screenshot below.

Is there an interpretation or explanation for this error?

PS: The plugin I had activated before this test run was OctoApp (1.0.12) ... but I do not necessarily think that this is to blame!?
PSS: The plugin Arc Welder I have currently also deactivated, because I suspected this to produce possibly incorrect GCodes.